Bug 984159 - SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'write' accesses on the directory ring.
SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'write'...
Status: CLOSED DUPLICATE of bug 984158
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e0e97effedac28ca32a9417fbd3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 01:53 EDT by Mark
Modified: 2013-07-16 04:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 04:40:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2013-07-13 01:53:26 EDT
Description of problem:
SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'write' accesses on the directory ring.

*****  Plugin catchall_labels (83.8 confidence) suggests  ********************

If you want to allow beam.smp to have write access on the ring directory
Then you need to change the label on ring
Do
# semanage fcontext -a -t FILE_TYPE 'ring'
where FILE_TYPE is one of the following: rabbitmq_var_lib_t, rabbitmq_var_log_t, rabbitmq_var_run_t. 
Then execute: 
restorecon -v 'ring'


*****  Plugin catchall (17.1 confidence) suggests  ***************************

If you believe that beam.smp should be allowed write access on the ring directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep beam.smp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:var_lib_t:s0
Target Objects                ring [ dir ]
Source                        beam.smp
Source Path                   /usr/lib64/erlang/erts-5.10.1/bin/beam.smp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           erlang-erts-R16B-0.3.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-63.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-301.fc19.x86_64 #1 SMP Thu
                              Jul 4 15:10:36 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-13 01:50:48 EDT
Last Seen                     2013-07-13 01:50:48 EDT
Local ID                      208304fe-4814-4977-8598-902f53ed0eb0

Raw Audit Messages
type=AVC msg=audit(1373694648.627:721): avc:  denied  { write } for  pid=4008 comm="beam.smp" name="ring" dev="dm-2" ino=1318981 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:var_lib_t:s0 tclass=dir


type=SYSCALL msg=audit(1373694648.627:721): arch=x86_64 syscall=access success=no exit=EACCES a0=7f66662404c0 a1=2 a2=0 a3=0 items=0 ppid=3863 pid=4008 auid=4294967295 uid=989 gid=988 euid=989 suid=989 fsuid=989 egid=988 sgid=988 fsgid=988 ses=4294967295 tty=pts2 comm=beam.smp exe=/usr/lib64/erlang/erts-5.10.1/bin/beam.smp subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: beam.smp,rabbitmq_beam_t,var_lib_t,dir,write

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-301.fc19.x86_64
type:           libreport
Comment 1 Mark 2013-07-13 02:13:50 EDT
Description of problem:
start riak

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-301.fc19.x86_64
type:           libreport
Comment 2 Miroslav Grepl 2013-07-16 04:40:34 EDT

*** This bug has been marked as a duplicate of bug 984158 ***

Note You need to log in before you can comment on or make changes to this bug.