Bug 984163 - SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'read' accesses on the directory riak.
SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'read' ...
Status: CLOSED DUPLICATE of bug 984158
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:692c2227aac98d0aeee0c628007...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 02:15 EDT by Mark
Modified: 2013-07-16 04:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 04:40:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2013-07-13 02:15:06 EDT
Description of problem:
start riak
SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'read' accesses on the directory riak.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that beam.smp should be allowed read access on the riak directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep beam.smp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:var_log_t:s0
Target Objects                riak [ dir ]
Source                        beam.smp
Source Path                   /usr/lib64/erlang/erts-5.10.1/bin/beam.smp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           erlang-erts-R16B-0.3.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-63.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-301.fc19.x86_64 #1 SMP Thu
                              Jul 4 15:10:36 UTC 2013 x86_64 x86_64
Alert Count                   33
First Seen                    2013-07-13 02:01:46 EDT
Last Seen                     2013-07-13 02:01:47 EDT
Local ID                      b6e04590-a189-434a-8abf-cad029c42ab5

Raw Audit Messages
type=AVC msg=audit(1373695307.321:946): avc:  denied  { read } for  pid=5960 comm="beam.smp" name="riak" dev="dm-2" ino=1318982 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:var_log_t:s0 tclass=dir


type=SYSCALL msg=audit(1373695307.321:946): arch=x86_64 syscall=access success=no exit=EACCES a0=7fc02bd81d40 a1=4 a2=0 a3=0 items=0 ppid=5808 pid=5960 auid=4294967295 uid=989 gid=988 euid=989 suid=989 fsuid=989 egid=988 sgid=988 fsgid=988 ses=4294967295 tty=pts2 comm=beam.smp exe=/usr/lib64/erlang/erts-5.10.1/bin/beam.smp subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: beam.smp,rabbitmq_beam_t,var_log_t,dir,read

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-16 04:40:24 EDT

*** This bug has been marked as a duplicate of bug 984158 ***

Note You need to log in before you can comment on or make changes to this bug.