Bug 984228 - SELinux is preventing /usr/bin/boinc_client from 'read' accesses on the file unix.
SELinux is preventing /usr/bin/boinc_client from 'read' accesses on the file ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:dd34fcb7a7f8e1d19c6175869c1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 15:52 EDT by Pavel Ondračka
Modified: 2013-08-14 22:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.11.1-100.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 22:54:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Ondračka 2013-07-13 15:52:27 EDT
Description of problem:
SELinux is preventing /usr/bin/boinc_client from 'read' accesses on the file unix.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that boinc_client should be allowed read access on the unix file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep boinc_client /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:boinc_t:s0
Target Context                system_u:object_r:proc_net_t:s0
Target Objects                unix [ file ]
Source                        boinc_client
Source Path                   /usr/bin/boinc_client
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           boinc-client-7.0.65-1.git79b00ef.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.6-200.fc18.x86_64 #1 SMP Thu
                              Jun 13 18:56:55 UTC 2013 x86_64 x86_64
Alert Count                   6
First Seen                    2013-07-01 08:02:33 CEST
Last Seen                     2013-07-12 22:41:19 CEST
Local ID                      daad25ae-bd0f-40df-b998-0e179e0fde45

Raw Audit Messages
type=AVC msg=audit(1373661679.380:350): avc:  denied  { read } for  pid=3934 comm="boinc_client" name="unix" dev="proc" ino=4026532002 scontext=system_u:system_r:boinc_t:s0 tcontext=system_u:object_r:proc_net_t:s0 tclass=file


type=SYSCALL msg=audit(1373661679.380:350): arch=x86_64 syscall=access success=no exit=EACCES a0=7f29db584620 a1=4 a2=7f29db58462e a3=1c items=0 ppid=1156 pid=3934 auid=4294967295 uid=991 gid=988 euid=991 suid=991 fsuid=991 egid=988 sgid=988 fsgid=988 ses=4294967295 tty=(none) comm=boinc_client exe=/usr/bin/boinc_client subj=system_u:system_r:boinc_t:s0 key=(null)

Hash: boinc_client,boinc_t,proc_net_t,file,read

audit2allow

#============= boinc_t ==============
allow boinc_t proc_net_t:file read;

audit2allow -R
require {
	type boinc_t;
}

#============= boinc_t ==============
kernel_read_network_state(boinc_t)


Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.6-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-16 07:30:26 EDT
Does everything work correctly?
Comment 2 Pavel Ondračka 2013-07-16 13:30:28 EDT
Probably yes. At the moment boinc seems to be crunching fine and I haven't noticed any failed boinc tasks, just the selinux warning.
Comment 3 Fedora Update System 2013-08-05 01:41:18 EDT
selinux-policy-3.11.1-99.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-99.fc18
Comment 4 Fedora Update System 2013-08-05 20:14:51 EDT
Package selinux-policy-3.11.1-99.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-99.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14256/selinux-policy-3.11.1-99.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-08-07 07:12:52 EDT
selinux-policy-3.11.1-100.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-100.fc18
Comment 6 Fedora Update System 2013-08-14 22:54:25 EDT
selinux-policy-3.11.1-100.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.