Bug 984229 - [abrt] icedax-1.1.11-14.fc18: register_index_position: Process /usr/bin/icedax was killed by signal 11 (SIGSEGV)
[abrt] icedax-1.1.11-14.fc18: register_index_position: Process /usr/bin/iceda...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
abrt_hash:c0dcd0b7073456a46b7a155f38b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 16:05 EDT by jd1008
Modified: 2016-11-24 10:53 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 22:39:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (71.08 KB, text/plain)
2013-07-13 16:05 EDT, jd1008
no flags Details
File: cgroup (125 bytes, text/plain)
2013-07-13 16:05 EDT, jd1008
no flags Details
File: core_backtrace (591 bytes, text/plain)
2013-07-13 16:06 EDT, jd1008
no flags Details
File: dso_list (940 bytes, text/plain)
2013-07-13 16:06 EDT, jd1008
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-13 16:06 EDT, jd1008
no flags Details
File: maps (4.95 KB, text/plain)
2013-07-13 16:06 EDT, jd1008
no flags Details
File: open_fds (138 bytes, text/plain)
2013-07-13 16:06 EDT, jd1008
no flags Details
File: proc_pid_status (924 bytes, text/plain)
2013-07-13 16:06 EDT, jd1008
no flags Details

  None (edit)
Description jd1008 2013-07-13 16:05:51 EDT
Description of problem:
I invoked 
 icedax dev=/dev/sr1 -vall cddb=0 -info-only

it crashed with the message:

index scan: 12...Memory fault(coredump)

Version-Release number of selected component:
icedax-1.1.11-14.fc18

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        cdda2wav dev=/dev/sr1 -vall -B cddb=1 -info-only
crash_function: register_index_position
executable:     /usr/bin/icedax
kernel:         3.9.9-201.fc18.x86_64
runlevel:       N 5
uid:            1008
var_log_messages: Jul 13 13:57:11 localhost abrt[4858]: Saved core dump of pid 4857 (/usr/bin/icedax) to /var/tmp/abrt/ccpp-2013-07-13-13:57:11-4857 (2686976 bytes)

Truncated backtrace:
Thread no. 1 (2 frames)
 #2 register_index_position at /usr/src/debug/cdrkit-1.1.11/icedax/toc.c:3093
 #3 ScanIndices at /usr/src/debug/cdrkit-1.1.11/icedax/toc.c:3199
Comment 1 jd1008 2013-07-13 16:05:55 EDT
Created attachment 773150 [details]
File: backtrace
Comment 2 jd1008 2013-07-13 16:05:58 EDT
Created attachment 773151 [details]
File: cgroup
Comment 3 jd1008 2013-07-13 16:06:00 EDT
Created attachment 773152 [details]
File: core_backtrace
Comment 4 jd1008 2013-07-13 16:06:03 EDT
Created attachment 773153 [details]
File: dso_list
Comment 5 jd1008 2013-07-13 16:06:06 EDT
Created attachment 773154 [details]
File: limits
Comment 6 jd1008 2013-07-13 16:06:08 EDT
Created attachment 773155 [details]
File: maps
Comment 7 jd1008 2013-07-13 16:06:11 EDT
Created attachment 773156 [details]
File: open_fds
Comment 8 jd1008 2013-07-13 16:06:13 EDT
Created attachment 773157 [details]
File: proc_pid_status
Comment 9 Frantisek Kluknavsky 2013-11-07 07:51:07 EST
I can not reproduce the crash. Works for me.

Maybe it will be interesting for glibc people, since the crash was inside a call to malloc(16).
Comment 10 Jeff Law 2013-11-07 09:00:16 EST
99.999% of the  time if you're getting an error in the allocator it's actually the fault of the user program or some library used by the user program, not glibc.
Comment 11 Carlos O'Donell 2013-11-07 22:39:44 EST
The failure location is not particularly informative other than it's in the use of fast small bins which are acceptable to corruption since their information is encoded right beside the allocation on the same page of memory. Therefore any overwrites by the application can corrupt the fast bins. The only way to harden the allocator is to disable fast bins, and add checking (which you can do via the API).

Marking CLOSED/WORKSFORME based on Frantisek's comments.

Note You need to log in before you can comment on or make changes to this bug.