Bug 984255 - [abrt] alacarte-3.7.90-1.fc19: codecs.py:351:write:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 54: ordinal not in range(128)
[abrt] alacarte-3.7.90-1.fc19: codecs.py:351:write:UnicodeDecodeError: 'ascii...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: alacarte (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jasper St. Pierre
Fedora Extras Quality Assurance
abrt_hash:0e456eb99b7a5743bc8e14f31df...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-14 00:21 EDT by Joe Zeff
Modified: 2015-02-17 11:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 11:08:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (3.25 KB, text/plain)
2013-07-14 00:21 EDT, Joe Zeff
no flags Details
File: core_backtrace (529 bytes, text/plain)
2013-07-14 00:21 EDT, Joe Zeff
no flags Details
File: environ (3.22 KB, text/plain)
2013-07-14 00:21 EDT, Joe Zeff
no flags Details

  None (edit)
Description Joe Zeff 2013-07-14 00:21:47 EDT
Description of problem:
I was trying to edit my menus after upgrading from F17 to 19, because the menu item for yumex had been unchecked.  When I checked it, this happened.

Version-Release number of selected component:
alacarte-3.7.90-1.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python2.7 -OOt /usr/bin/alacarte
dso_list:       python-libs-2.7.5-3.fc19.i686
executable:     /usr/bin/alacarte
kernel:         3.9.9-301.fc19.i686.PAE
runlevel:       N 5
uid:            1000

Truncated backtrace:
codecs.py:351:write:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 54: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 342, in on_item_tree_show_toggled
    self.editor.setVisible(item, True)
  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 182, in setVisible
    self.writeItem(item, NoDisplay=False)
  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 408, in writeItem
    f.write(contents)
  File "/usr/lib/python2.7/codecs.py", line 691, in write
    return self.writer.write(data)
  File "/usr/lib/python2.7/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 54: ordinal not in range(128)

Local variables in innermost frame:
self: <closed file '/home/joe/.local/share/applications/yumex-local.desktop', mode 'wb' at 0x8d01d88>
object: '[Desktop Entry]\nName=Yumex Package Installer\nName[bg]=\xd0\x98\xd0\xbd\xd1\x81\xd1\x82\xd0\xb0\xd0\xbb\xd0\xb0\xd1\x82\xd0\xbe\xd1\x80 \xd0\xbd\xd0\xb0 \xd0\xbf\xd0\xb0\xd0\xba\xd0\xb5\xd1\x82\xd0\xb8 Yumex\nName[da]=Yumex Pakke installations v\xc3\xa6rkt\xc3\xb8j\nName[de]=Yumex Paketinstallation\nName[fr]=Installateur de paquets Yumex\nName[ja]=Yumex\xe3\x83\x91\xe3\x83\x83\xe3\x82\xb1\xe3\x83\xbc\xe3\x82\xb8\xe3\x82\xa4\xe3\x83\xb3\xe3\x82\xb9\xe3\x83\x88\xe3\x83\xbc\xe3\x83\xa9\xe3\x83\xbc\nName[nl]=Yumex Package Installer\nName[pl]=Instalator pakiet\xc3\xb3w Yumex\nName[pt]=Yumex - Instalador de pacotes\nName[uk]=\xd0\x9f\xd1\x80\xd0\xbe\xd0\xb3\xd1\x80\xd0\xb0\xd0\xbc\xd0\xb0 \xd0\xb4\xd0\xbb\xd1\x8f \xd0\xb2\xd1\x81\xd1\x82\xd0\xb0\xd0\xbd\xd0\xbe\xd0\xb2\xd0\xbb\xd0\xb5\xd0\xbd\xd0\xbd\xd1\x8f \xd0\xbf\xd0\xb0\xd0\xba\xd1\x83\xd0\xbd\xd0\xba\xd1\x96\xd0\xb2 Yumex\nComment=Install local packages on system\nComment[bg]=\xd0\x98\xd0\xbd\xd1\x81\xd1\x82\xd0\xb0\xd0\xbb\xd0\xb8\xd1\x80\xd0\xb0\xd0\xbd\xd0\xb5 \xd0\xbb\xd0\xbe\xd0\xba\xd0\xb0\xd0\xbb\xd0\xbd\xd0\xb8 \xd0\xbf\xd0\xb0\xd0\xba\xd0\xb5\xd1\x82\xd0\xb8 \xd0\xbd\xd0\xb0 \xd1\x81\xd0\xb8\xd1\x81\xd1\x82\xd0\xb5\xd0\xbc\xd0\xb0\xd1\x82\xd0\xb0\nComment[da]=Installer lokale pakker p\xc3\xa5 systemet\nComment[de]=Lokale Pakete auf dem System installieren\nComment[fr]=Installer des paquets locaux sur le syst\xc3\xa8me\nComment[ja]=\xe3\x83\xad\xe3\x83\xbc\xe3\x82\xab\xe3\x83\xab\xe3\x83\x91\xe3\x83\x83\xe3\x82\xb1\xe3\x83\xbc\xe3\x82\xb8\xe3\x82\x92\xe3\x82\xb7\xe3\x82\xb9\xe3\x83\x86\xe3\x83\xa0\xe3\x81\xab\xe3\x82\xa4\xe3\x83\xb3\xe3\x82\xb9\xe3\x83\x88\xe3\x83\xbc\xe3\x83\xab\xe3\x81\x97\xe3\x81\xbe\xe3\x81\x99\nComment[nl]=Installeer lokale pakketten op systeem\nComment[pl]=Instaluje lokalne pakiety w systemie\nComment[pt]=Instalar pacotes locais\nComment[uk]=\xd0\x92\xd1\x81\xd1\x82\xd0\xb0\xd0\xbd\xd0\xbe\xd0\xb2\xd0\xb8\xd1\x82\xd0\xb8 \xd0\xbb\xd0\xbe\xd0\xba\xd0\xb0\xd0\xbb\xd1\x8c\xd0\xbd\xd1\x96 \xd0\xbf\xd0\xb0\xd0\xba\xd1\x83\xd0\xbd\xd0\xba\xd0\xb8 \xd1\x83 \xd1\x81\xd0\xb8\xd1\x81\xd1\x82\xd0\xb5\xd0\xbc\xd1\x96\nCategories=System;\nExec=/usr/bin/yumex -X install %F\nTerminal=false\nType=Application\nIcon=yumex\nStartupNotify=true\nNoDisplay=false\nMimeType=application/x-rpm;application/x-redhat-package-manager;\n\n'
Comment 1 Joe Zeff 2013-07-14 00:21:51 EDT
Created attachment 773219 [details]
File: backtrace
Comment 2 Joe Zeff 2013-07-14 00:21:53 EDT
Created attachment 773220 [details]
File: core_backtrace
Comment 3 Joe Zeff 2013-07-14 00:21:56 EDT
Created attachment 773221 [details]
File: environ
Comment 4 Joe Zeff 2013-07-14 00:25:53 EDT
After I reported this, I tried to complete my work on the menus, but none of my changes took effect.
Comment 5 Joe Zeff 2013-08-01 19:24:21 EDT
I've just upgraded my desktop to F19 (The other upgrade was my laptop.) and tried running alacarte.  Although I got the same error, the changes seen to have been kept.
Comment 7 Fedora End Of Life 2015-01-09 13:54:14 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2015-02-17 11:08:22 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.