Bug 984292 - Non human-readable event in engine.log during adding a new host
Non human-readable event in engine.log during adding a new host
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Martin Perina
vvyazmin@redhat.com
infra
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-14 10:09 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 14:05 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-19 03:17:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs rhevm, vdsm (561.48 KB, application/x-gzip)
2013-07-14 10:09 EDT, vvyazmin@redhat.com
no flags Details
oVirt 3.3 logs (194.29 KB, application/x-compressed-tar)
2013-07-19 03:16 EDT, Martin Perina
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-07-14 10:09:32 EDT
Created attachment 773324 [details]
## Logs rhevm, vdsm

Description of problem:
Non human-readable event during installation host via RHEVM UI

Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS5 environment:

RHEVM: rhevm-3.3.0-0.7.master.el6ev.noarch
VDSM: vdsm-4.11.0-121.git082925a.el6.x86_64
LIBVIRT: libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.355.el6_4.5.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64

How reproducible:
Unknown

Steps to Reproduce:
Install clean installation RHEVM 3.3 IS5 
 Adding a new host
Host get status “Installing”, and then get status “Up”

Actual results:
In “engine.log” I get ERROR: 
2013-07-14 14:40:10,242 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException
2013-07-14 14:40:10,249 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) Command PollVDS execution failed. Exception: RuntimeException: java.util.concurrent.ExecutionException: java.lang.reflect.Invocati
onTargetException

Expected results:
Get more human-readable event, for example: 
Host in installation process
Host in not reachable yet, please wait
VDSM not start yet, because host in installation process

Impact on user:
None

Workaround:
None

Additional info:

/var/log/ovirt-engine/engine.log

2013-07-14 14:39:59,150 INFO  [org.ovirt.engine.core.bll.InstallerMessages] (VdsDeploy) Installation tigris01.scl.lab.tlv.redhat.com: Stage: Pre-termination
2013-07-14 14:39:59,179 INFO  [org.ovirt.engine.core.bll.InstallerMessages] (VdsDeploy) Installation tigris01.scl.lab.tlv.redhat.com: Retrieving installation logs to: '/var/log/ovirt-engine/host-deploy/ovirt-20130714143959-tigris01.scl.l
ab.tlv.redhat.com-67c4ab77.log'
2013-07-14 14:40:09,297 INFO  [org.ovirt.engine.core.bll.InstallerMessages] (VdsDeploy) Installation tigris01.scl.lab.tlv.redhat.com: Stage: Termination
2013-07-14 14:40:10,242 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException
2013-07-14 14:40:10,249 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) Command PollVDS execution failed. Exception: RuntimeException: java.util.concurrent.ExecutionException: java.lang.reflect.Invocati
onTargetException
2013-07-14 14:40:10,756 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException
2013-07-14 14:40:10,756 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) Command PollVDS execution failed. Exception: RuntimeException: java.util.concurrent.ExecutionException: java.lang.reflect.Invocati
onTargetException
2013-07-14 14:40:11,278 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException
2013-07-14 14:40:11,278 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) Command PollVDS execution failed. Exception: RuntimeException: java.util.concurrent.ExecutionException: java.lang.reflect.Invocati
onTargetException
2013-07-14 14:40:11,787 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException
2013-07-14 14:40:11,787 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) Command PollVDS execution failed. Exception: RuntimeException: java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException
2013-07-14 14:40:12,297 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException
2013-07-14 14:40:12,297 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (pool-5-thread-6) Command PollVDS execution failed. Exception: RuntimeException: java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException


/var/log/vdsm/vdsm.log
Comment 1 Martin Perina 2013-07-19 03:16:26 EDT
Created attachment 775656 [details]
oVirt 3.3 logs
Comment 2 Martin Perina 2013-07-19 03:17:48 EDT
Fixed in latest oVirt 3.3

Note You need to log in before you can comment on or make changes to this bug.