Bug 984299 - nova live-migration of volume-backed VM fails because of image is None [NEEDINFO]
nova live-migration of volume-backed VM fails because of image is None
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
3.0
x86_64 Linux
unspecified Severity high
: beta
: 4.0
Assigned To: Nikola Dipanov
Jaroslav Henner
OtherQA
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-14 11:29 EDT by Jaroslav Henner
Modified: 2016-04-22 01:02 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-0.23.rc1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 18:54:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mlopes: needinfo? (ndipanov)


Attachments (Terms of Use)
log (14.07 KB, text/plain)
2013-07-14 11:29 EDT, Jaroslav Henner
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1199811 None None None Never
OpenStack gerrit 36654 None None None Never

  None (edit)
Description Jaroslav Henner 2013-07-14 11:29:49 EDT
Created attachment 773363 [details]
log

Description of problem:
cinder create --image-id ab24ccbd-4c89-4444-b0b2-a06a79c44306 --display-name my-bootable-vol 3
nova boot --flavor 1 --block_device_mapping vda=0ea63954-0a9a-4df7-b5a9-08afd0981dcc:::0 volume_backed
nova live-migration volume_backed

resultes in "migration failed"


Version-Release number of selected component (if applicable):
I believe it was
openstack-nova-2013.1.2-4.el6ost.noarch.rpm
openstack-cinder-2013.1.2-3.el6ost.noarch.rpm

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Nikola Dipanov 2013-07-15 05:19:37 EDT
Fix proposed to the stable/grizzly branch upstream.
Comment 5 Scott Lewis 2013-11-19 11:54:25 EST
Auto adding >= MODIFIED bugs to beta
Comment 8 Jaroslav Henner 2013-12-05 10:33:37 EST
before:
| hostId                               | a9cd410836ef073fe0a328db1aa2b8ab7e2af89e049073be4806e4c9 |
after:
| hostId                               | d3e2ea6aa1bdc1ab14c08cb5c53fa4d3c6a872adc755c3ea82c2cbbb |


It worked!
Comment 11 errata-xmlrpc 2013-12-19 18:54:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.