This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 984379 - SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from using the 'getsched' accesses on a process.
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from using ...
Status: CLOSED DUPLICATE of bug 984377
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5d479aa2695d23d378acd536d7b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 02:09 EDT by Moez Roy
Modified: 2013-07-15 04:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 04:43:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-07-15 02:09:37 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from using the 'getsched' accesses on a process.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that wineserver should be allowed getsched access on processes labeled unconfined_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wineserver /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                 [ process ]
Source                        wineserver
Source Path                   /opt/teamviewer8/tv_bin/wine/bin/wineserver
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-98.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-201.fc18.x86_64 #1 SMP Fri
                              Jul 5 16:42:02 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-07-13 08:25:07 PDT
Last Seen                     2013-07-13 08:30:50 PDT
Local ID                      cfaf9252-5176-4c5a-9ea9-8a1cc1a678ce

Raw Audit Messages
type=AVC msg=audit(1373729450.119:379): avc:  denied  { getsched } for  pid=1891 comm="wineserver" scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process


type=SYSCALL msg=audit(1373729450.119:379): arch=i386 syscall=mq_timedsend success=yes exit=EBUSY a0=874 a1=80 a2=ffc0e500 a3=80 items=0 ppid=1 pid=1891 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=wineserver exe=/opt/teamviewer8/tv_bin/wine/bin/wineserver subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: wineserver,initrc_t,unconfined_t,process,getsched

audit2allow

#============= initrc_t ==============
allow initrc_t unconfined_t:process getsched;

audit2allow -R
require {
	type unconfined_t;
	type initrc_t;
	class process getsched;
}

#============= initrc_t ==============
allow initrc_t unconfined_t:process getsched;


Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-201.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-15 04:43:28 EDT

*** This bug has been marked as a duplicate of bug 984377 ***

Note You need to log in before you can comment on or make changes to this bug.