Bug 984380 - SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'getattr' accesses on the unix_stream_socket unix_stream_socket.
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'getat...
Status: CLOSED DUPLICATE of bug 984377
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6348b8e27dcb9eb5dd5f3639ff5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 02:10 EDT by Moez Roy
Modified: 2013-07-15 04:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 04:43:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-07-15 02:10:18 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'getattr' accesses on the unix_stream_socket unix_stream_socket.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that wineserver should be allowed getattr access on the unix_stream_socket unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wineserver /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                unix_stream_socket [ unix_stream_socket ]
Source                        wineserver
Source Path                   /opt/teamviewer8/tv_bin/wine/bin/wineserver
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-98.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-201.fc18.x86_64 #1 SMP Fri
                              Jul 5 16:42:02 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-07-13 08:25:08 PDT
Last Seen                     2013-07-13 08:30:52 PDT
Local ID                      8a9c1de9-c81a-47a0-a8d6-5aa33fc06107

Raw Audit Messages
type=AVC msg=audit(1373729452.22:382): avc:  denied  { getattr } for  pid=1891 comm="wineserver" path="socket:[27797]" dev="sockfs" ino=27797 scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket


type=SYSCALL msg=audit(1373729452.22:382): arch=i386 syscall=removexattr success=yes exit=0 a0=29 a1=ffc0e540 a2=4bf61000 a3=29 items=0 ppid=1 pid=1891 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=wineserver exe=/opt/teamviewer8/tv_bin/wine/bin/wineserver subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: wineserver,initrc_t,unconfined_t,unix_stream_socket,getattr

audit2allow

#============= initrc_t ==============
allow initrc_t unconfined_t:unix_stream_socket getattr;

audit2allow -R
require {
	type unconfined_t;
	type initrc_t;
	class unix_stream_socket getattr;
}

#============= initrc_t ==============
allow initrc_t unconfined_t:unix_stream_socket getattr;


Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-201.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-15 04:43:21 EDT

*** This bug has been marked as a duplicate of bug 984377 ***

Note You need to log in before you can comment on or make changes to this bug.