Bug 984387 - SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /home/user9/.config/teamviewer8/drive_c/windows/system32/winemenubuilder.exe.
SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /home...
Status: CLOSED DUPLICATE of bug 984377
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7e581c74403e1e283e8fd364bb5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 02:15 EDT by Moez Roy
Modified: 2013-07-15 07:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 07:16:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-07-15 02:15:47 EDT
Description of problem:
SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /home/user9/.config/teamviewer8/drive_c/windows/system32/winemenubuilder.exe.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that bash should be allowed getattr access on the winemenubuilder.exe file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep TeamViewer /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                unconfined_u:object_r:config_home_t:s0
Target Objects                /home/user9/.config/teamviewer8/drive_c/windows/sy
                              stem32/winemenubuilder.exe [ file ]
Source                        TeamViewer
Source Path                   /usr/bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.2.45-1.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-98.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-201.fc18.x86_64 #1 SMP Fri
                              Jul 5 16:42:02 UTC 2013 x86_64 x86_64
Alert Count                   5
First Seen                    2013-07-11 01:24:23 PDT
Last Seen                     2013-07-13 08:30:59 PDT
Local ID                      33e8d5b1-6929-417f-bb0d-551579ca09ab

Raw Audit Messages
type=AVC msg=audit(1373729459.401:394): avc:  denied  { getattr } for  pid=2373 comm="TeamViewer_Desk" path="/home/user9/.config/teamviewer8/drive_c/windows/system32/winemenubuilder.exe" dev="dm-3" ino=45876415 scontext=system_u:system_r:init_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file


type=SYSCALL msg=audit(1373729459.401:394): arch=x86_64 syscall=stat success=yes exit=0 a0=cd7bd0 a1=7fff8cd94620 a2=7fff8cd94620 a3=8 items=0 ppid=1450 pid=2373 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=TeamViewer_Desk exe=/usr/bin/bash subj=system_u:system_r:init_t:s0 key=(null)

Hash: TeamViewer,init_t,config_home_t,file,getattr

audit2allow

#============= init_t ==============
allow init_t config_home_t:file getattr;

audit2allow -R
require {
	type init_t;
}

#============= init_t ==============
gnome_read_home_config(init_t)


Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-201.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-15 07:16:11 EDT

*** This bug has been marked as a duplicate of bug 984377 ***

Note You need to log in before you can comment on or make changes to this bug.