Bug 984396 - "Could not find suitable distribution for 'gevent'" error shows when git push or restore snapshot for python2.7 app.
"Could not find suitable distribution for 'gevent'" error shows when git push...
Status: CLOSED DUPLICATE of bug 981150
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Hiro Asari
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 02:42 EDT by Lei Zhang
Modified: 2015-05-14 19:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 15:44:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lei Zhang 2013-07-15 02:42:10 EDT
Description of problem:
Given a normal python2.7 app, change something in local repo and git push. error is shown.
remote: Couldn't find index page for 'gevent' (maybe misspelled?)
remote: Scanning index of all packages (this may take a while)
remote: Reading http://mirror1.ops.rhcloud.com/mirror/python/web/simple/
remote: No local packages or download links found for gevent
remote: error: Could not find suitable distribution for Requirement.parse('gevent')
remote:  - Done processing setup.py


When python-2.7 app do restore, also has this error:
ERROR:  database "mypython27" already exists
Couldn't find index page for 'gevent' (maybe misspelled?)
No local packages or download links found for gevent
error: Could not find suitable distribution for Requirement.parse('gevent')

Version-Release number of selected component (if applicable):
devenv-stage-404

How reproducible:
always

Steps to Reproduce:
1. create a normal python-2.7 app.  
2. change something in local repo and git push 
3. or do snapshot save and restore snapshot 

Actual results:
Error "Could not find suitable distribution for Requirement.parse('gevent')" shows

Expected results:
No error message should be shown.

Additional info:
Comment 1 Hiro Asari 2013-07-15 15:44:52 EDT
Our mirror needs to be fixed. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 981150 ***

Note You need to log in before you can comment on or make changes to this bug.