Bug 984425 - journalctl does not honor pager options ($LESS)
journalctl does not honor pager options ($LESS)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 04:20 EDT by Kamil Páral
Modified: 2013-07-25 21:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 21:02:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2013-07-15 04:20:51 EDT
Description of problem:
journalctl does not honor 'less' environment options. I have some options configured:

$ echo $LESS
--ignore-case --RAW-CONTROL-CHARS --quit-if-one-screen --no-init

But if I run "journalctl", I don't have case insensitive search enabled. The same problem is with "SYSTEMD_PAGER=less journalctl". However, if I run "journalctl | less", everything works correctly.

Since journalctl uses less by default, shouldn't it invoke it the same way the user is used to (honoring $LESS env variable)? It would be convenient and appreciated.

Version-Release number of selected component (if applicable):
systemd-204-9.fc19.x86_64
less-458-3.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. configure $LESS env var
2. run journalctl and see that the less configuration does not apply
Comment 1 Lennart Poettering 2013-07-25 21:02:02 EDT
We can#t really do that, because we require a number of LESS values set. You can still override this by assing the arguments to $PAGER as command line arguments.

See https://bugzilla.redhat.com/show_bug.cgi?id=868383

Note You need to log in before you can comment on or make changes to this bug.