Bug 984473 - Chapter 2. Maven Guide needs changes
Chapter 2. Maven Guide needs changes
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: EAP 6.3.0
Assigned To: Misha H. Ali
Russell Dickenson
: Documentation, EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 06:38 EDT by Nikoleta Ziakova
Modified: 2014-08-14 11:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 10:34:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikoleta Ziakova 2013-07-15 06:38:39 EDT
1)
Document URL: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/chap-Maven_Guide.html

Section Number and Name: 
2.1.1. About the Maven Repository

Describe the issue: 
Typo in sentence: Remote repositories are accessed using common protocols such as http:// for a repository on an HTTP server or file:// for a repository a file server.

Suggestions for improvement: 
Remote repositories are accessed using common protocols such as http:// for a repository on an HTTP server or file:// for a repository on a file server.

2)
Document URL: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/chap-Maven_Guide.html

Section Number and Name: 
2.1.4. About the Maven Settings File

Describe the issue: 
Incorrect version in example of settings.xml, 2x line:
<url>file:///path/to/repo/jboss-eap-6.0-maven-repository</url>

Suggestions for improvement: 
<url>file:///path/to/repo/jboss-eap-6.1-maven-repository</url>

3)
Document URL: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/Install_the_JBoss_Enterprise_Application_Platform_6_Maven_Repository_Locally.html

Section Number and Name: 
2.2.3. Install the JBoss EAP 6 Maven Repository Locally

Describe the issue: 
2x incorrect version, lines:
Find "Application Platform 6.1.0 Maven Repository" in the list. 
This creates a Maven repository directory called jboss-eap-6.1.0.maven-repository. 

Suggestions for improvement: 
Replace string 6.1.0 by 6.1.1

4)
Document URL: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/Install_the_JBoss_Enterprise_Application_Platform_6_Maven_Repository_Using_Nexus_Maven_Repository_Manager.html

Section Number and Name: 
2.2.5. Install the JBoss EAP 6 Maven Repository Using Nexus Maven Repository Manager

Describe the issue: 
Incorrect version, line:
Find "Application Platform 6.1.0 Maven Repository" in the list. 

Suggestions for improvement: 
Replace string 6.1.0 by 6.1.1

5)
Document URL: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.1/html-single/Development_Guide/index.html#Configure_the_JBoss_Enterprise_Application_Platform_Maven_Repository

Section Number and Name: 
2.3.1. Configure the JBoss EAP Maven Repository

Describe the issue: 
Missing "6" in the section name

Suggestions for improvement: 
2.3.1. Configure the JBoss EAP 6 Maven Repository

6)
Document URL: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/Configure_the_JBoss_Enterprise_Application_Platform_Maven_Repository_Using_the_Maven_Settings.html

Section Number and Name: 
2.3.2. Configure the JBoss EAP 6 Maven Repository Using the Maven Settings

Describe the issue: 
5x incorrect version in string: jboss-eap-6.0.0-maven-repository

Suggestions for improvement: 
Replace string 6.0.0 by 6.1.1

7)
Document URL: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/Configure_the_JBoss_Enterprise_Application_Platform_Maven_Repository_Using_the_Project_POM.html

Section Number and Name: 
2.3.3. Configure the JBoss EAP 6 Maven Repository Using the Project POM

Describe the issue: 
5x incorrect version in string: jboss-eap-6.0.0-maven-repository

Suggestions for improvement: 
Replace string 6.0.0 by 6.1.1
Comment 1 Nikoleta Ziakova 2013-10-01 07:52:04 EDT
Issues in Description are still valid in EAP 6.2.0. However the EAP version was changed and some previous suggestions for improvement are outdated now because of this. 

New document URL: http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html-single/Development_Guide/index.html#chap-Maven_Guide
Comment 2 Nikoleta Ziakova 2013-10-01 07:55:52 EDT
Issues 2), 3), 6) and 7):
Name of the Maven repository directory is "jboss-eap-6.2.0.Beta1-maven-repository" and it will probably be changed again to jboss-eap-6.2.0.GA-maven-repository for GA.
Comment 3 Nikoleta Ziakova 2013-10-01 07:56:39 EDT
Issues 3) and 4):
Correct item in list in Customer Portal at https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=appplatform to find is "Red Hat JBoss Enterprise Application Platform 6.2.0 Maven Repository" instead of "Application Platform 6.1.0 Maven Repository".
Comment 4 Nikoleta Ziakova 2013-10-01 09:57:36 EDT
One more issue:

8)
Document URL: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html/Development_Guide/Configure_the_JBoss_Enterprise_Application_Platform_Maven_Repository_Using_the_Maven_Settings.html

Section Number and Name: 
2.3.2. Configure the JBoss EAP 6 Maven Repository Using the Maven Settings

Describe the issue: 
The following two sentences do not make sense since they are in the Development Guide:

  For information on how to install the repository, refer to the chapter entitled Maven Guide in the Development Guide for JBoss EAP 6 on https://access.redhat.com/site/documentation/JBoss_Enterprise_Application_Platform/.

  For more information about the location of the settings and how they behave, refer to the chapter entitled Maven Guide in the Development Guide for JBoss EAP 6 on https://access.redhat.com/site/documentation/JBoss_Enterprise_Application_Platform/.

Suggestions for improvement: 
Link to the appropriate sections
Comment 8 Misha H. Ali 2014-02-10 20:36:37 EST
(In reply to Nikoleta Ziakova from comment #0)
> 1)
> Document URL: 
> http://documentation-devel.engineering.redhat.com/docs/en-US/
> JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/chap-
> Maven_Guide.html
> 
> Section Number and Name: 
> 2.1.1. About the Maven Repository
> 
> Describe the issue: 
> Typo in sentence: Remote repositories are accessed using common protocols
> such as http:// for a repository on an HTTP server or file:// for a
> repository a file server.
> 
> Suggestions for improvement: 
> Remote repositories are accessed using common protocols such as http:// for
> a repository on an HTTP server or file:// for a repository on a file server.

Fixed as recommended.

> 2)
> Document URL: 
> http://documentation-devel.engineering.redhat.com/docs/en-US/
> JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/chap-
> Maven_Guide.html
> 
> Section Number and Name: 
> 2.1.4. About the Maven Settings File
> 
> Describe the issue: 
> Incorrect version in example of settings.xml, 2x line:
> <url>file:///path/to/repo/jboss-eap-6.0-maven-repository</url>
> 
> Suggestions for improvement: 
> <url>file:///path/to/repo/jboss-eap-6.1-maven-repository</url>

Fixed as suggested.

> 3)
> Document URL: 
> http://documentation-devel.engineering.redhat.com/docs/en-US/
> JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/
> Install_the_JBoss_Enterprise_Application_Platform_6_Maven_Repository_Locally.
> html
> 
> Section Number and Name: 
> 2.2.3. Install the JBoss EAP 6 Maven Repository Locally
> 
> Describe the issue: 
> 2x incorrect version, lines:
> Find "Application Platform 6.1.0 Maven Repository" in the list. 
> This creates a Maven repository directory called
> jboss-eap-6.1.0.maven-repository. 
> 
> Suggestions for improvement: 
> Replace string 6.1.0 by 6.1.1

This is now changed to 6.3.0.

> 4)
> Document URL: 
> http://documentation-devel.engineering.redhat.com/docs/en-US/
> JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/
> Install_the_JBoss_Enterprise_Application_Platform_6_Maven_Repository_Using_Ne
> xus_Maven_Repository_Manager.html
> 
> Section Number and Name: 
> 2.2.5. Install the JBoss EAP 6 Maven Repository Using Nexus Maven Repository
> Manager
> 
> Describe the issue: 
> Incorrect version, line:
> Find "Application Platform 6.1.0 Maven Repository" in the list. 
> 
> Suggestions for improvement: 
> Replace string 6.1.0 by 6.1.1

Changed version strings to 6.3.0

> 5)
> Document URL: 
> http://documentation-devel.engineering.redhat.com/docs/en-US/
> JBoss_Enterprise_Application_Platform/6.1/html-single/Development_Guide/
> index.
> html#Configure_the_JBoss_Enterprise_Application_Platform_Maven_Repository
> 
> Section Number and Name: 
> 2.3.1. Configure the JBoss EAP Maven Repository
> 
> Describe the issue: 
> Missing "6" in the section name
> 
> Suggestions for improvement: 
> 2.3.1. Configure the JBoss EAP 6 Maven Repository

Changed topic title to include 6 for consistency.

> 6)
> Document URL: 
> http://documentation-devel.engineering.redhat.com/docs/en-US/
> JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/
> Configure_the_JBoss_Enterprise_Application_Platform_Maven_Repository_Using_th
> e_Maven_Settings.html
> 
> Section Number and Name: 
> 2.3.2. Configure the JBoss EAP 6 Maven Repository Using the Maven Settings
> 
> Describe the issue: 
> 5x incorrect version in string: jboss-eap-6.0.0-maven-repository
> 
> Suggestions for improvement: 
> Replace string 6.0.0 by 6.1.1

Updated all older version strings to 6.3 or 6.3.0 as required.
 
> 7)
> Document URL: 
> http://documentation-devel.engineering.redhat.com/docs/en-US/
> JBoss_Enterprise_Application_Platform/6.1/html/Development_Guide/
> Configure_the_JBoss_Enterprise_Application_Platform_Maven_Repository_Using_th
> e_Project_POM.html
> 
> Section Number and Name: 
> 2.3.3. Configure the JBoss EAP 6 Maven Repository Using the Project POM
> 
> Describe the issue: 
> 5x incorrect version in string: jboss-eap-6.0.0-maven-repository
> 
> Suggestions for improvement: 
> Replace string 6.0.0 by 6.1.1

Updated all version strings to 6.3.0
Comment 10 Scott Mumford 2014-02-26 00:13:47 EST
Moving to ON_QA.

The changes should be available for review on the documentation stage within an hour or so from this comment.

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/
Comment 11 Scott Mumford 2014-02-26 00:15:46 EST
Moving to ON_QA.

The changes should be available for review on the documentation stage within an hour or so from this comment.

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/
Comment 12 Nikoleta Ziakova 2014-02-26 09:14:29 EST
1+5) OK, fixed

2) fixed, but deprecatd now, <url>file:///path/to/repo/jboss-eap-6.1-maven-repository</url> should be replaced by <url>file:///path/to/repo/jboss-eap-6.3-maven-repository</url>

3+4+6+7) some fixed to 6.3 but some remained 6.2, see BZ 1070209
Comment 16 Nikoleta Ziakova 2014-03-11 07:37:32 EDT
I have checked all items from this issue and they are fixed. However I would suggest one change in the issue in my comment #4. 

Now the sentence is: 
"For information on how to install the repository, refer to the Maven Guide chapter."

While this sentence is also in Maven Guide chapter, it would be better to refer to specific section of this chapter (actually it is 2.2. Install Maven and the JBoss Maven Repository).
Comment 17 Russell Dickenson 2014-07-15 22:57:06 EDT
Note to CCS
===========
When checking the state of this BZ ticket I found that the change requested in comment 16 had already been completed.


Note to QE
==========
The issue mentioned in comment 16 has been resolved by providing a direct link to section 2.2.2, “Install the JBoss EAP 6 Maven Repository”. The updated text is available for review in revision 6.3.0-27 (or higher) of the Development Guide [1].


[1] https://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html-single/Development_Guide/index.html#Configure_the_JBoss_Enterprise_Application_Platform_Maven_Repository_Using_the_Maven_Settings
Comment 18 Nikoleta Ziakova 2014-07-16 07:55:35 EDT
Verified in revision 6.3.0-27

Note You need to log in before you can comment on or make changes to this bug.