Bug 984550 - /etc/gdm/Xsession[12795]: JS LOG: error reading: /sys/devices/virtual/thermal/thermal_zone0/temp
/etc/gdm/Xsession[12795]: JS LOG: error reading: /sys/devices/virtual/thermal...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 09:22 EDT by udo
Modified: 2013-08-05 10:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 10:26:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udo 2013-07-15 09:22:51 EDT
Description of problem:
/var/.og/messages is spammed every few seconds with the message from the summary.
My kernel has 
  <*>   Thermal Zone    (CONFIG_ACPI_THERMAL)
but indeed /sys/devices/virtual/thermal/thermal_zone0/temp does not exist. Please fix the spamming.
Is it perhaps that system-monitor trying to read the temperatures?

Version-Release number of selected component (if applicable):
gdm-3.8.3-2.fc19.x86_64

How reproducible:
Boot into Fedora 19 using kernel.org 3.9.9.
Check /var/log/messages after a while

Actual results:
See above

Expected results:
No such messages.

Additional info:
# grep ACPI .config
# Power management and ACPI options
CONFIG_ACPI=y
# CONFIG_ACPI_PROCFS is not set
# CONFIG_ACPI_PROCFS_POWER is not set
# CONFIG_ACPI_EC_DEBUGFS is not set
# CONFIG_ACPI_PROC_EVENT is not set
# CONFIG_ACPI_AC is not set
# CONFIG_ACPI_BATTERY is not set
CONFIG_ACPI_BUTTON=m
# CONFIG_ACPI_VIDEO is not set
CONFIG_ACPI_FAN=m
CONFIG_ACPI_DOCK=y
CONFIG_ACPI_I2C=y
CONFIG_ACPI_PROCESSOR=y
# CONFIG_ACPI_PROCESSOR_AGGREGATOR is not set
CONFIG_ACPI_THERMAL=y
# CONFIG_ACPI_CUSTOM_DSDT is not set
CONFIG_ACPI_INITRD_TABLE_OVERRIDE=y
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
# CONFIG_ACPI_PCI_SLOT is not set
CONFIG_ACPI_CONTAINER=y
# CONFIG_ACPI_SBS is not set
# CONFIG_ACPI_HED is not set
# CONFIG_ACPI_CUSTOM_METHOD is not set
CONFIG_ACPI_BGRT=y
# CONFIG_ACPI_APEI is not set
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_ACPI_CPUFREQ_CPB=y
CONFIG_PNPACPI=y
CONFIG_ATA_ACPI=y
# CONFIG_PATA_ACPI is not set
# ACPI drivers
# ACPI drivers
# CONFIG_SENSORS_ACPI_POWER is not set
Comment 1 udo 2013-08-05 10:26:49 EDT
On 2013-08-05 13:49, Porjo wrote:> I resolved this by going into system-monitor preferences to Thermal ->
> Sensor and selecting "Coretemp - temp1". Previously, that setting was
> blank. Since that change, I've seen no further errors in the log.

Yes, setting that Sensor makes the stream of these error messages go away.

Note You need to log in before you can comment on or make changes to this bug.