Bug 984596 - Uncaught exception: (TypeError) Object DocBuilderView has no method 'iW'
Uncaught exception: (TypeError) Object DocBuilderView has no method 'iW'
Status: CLOSED WORKSFORME
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
: 990809 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 10:08 EDT by sgilda
Modified: 2014-06-12 22:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-12 21:10:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of dialog with exception. (16.86 KB, image/png)
2013-07-15 10:08 EDT, sgilda
no flags Details

  None (edit)
Description sgilda 2013-07-15 10:08:02 EDT
Created attachment 773773 [details]
Screen shot of dialog with exception.

Description of problem:
To recreate:
- Search for a CSP map topic ID, for example: 11864.
- It brings you here: http://skynet.usersys.redhat.com:8080/pressgang-ccms-ui/#SearchResultsAndTopicView;query;topicIds=11864
- Leave the page open and go do something else for a while (read mail, get coffee). I'm not sure how long, but 10 minutes is probably safe. :-)
- Come back to the page and click on "DocBuilder" in the left menu.
- You get a dialog box with above message.

This is probably a timeout issue.

Screen shot attached.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 sgilda 2013-07-15 10:45:02 EDT
This is only an issue with Google Chrome. I am on Version 28.0.1500.71.

I can not reproduce it in Firefox.

Not sure it's worth your time to look into this or fix it.
Comment 2 sgilda 2013-07-15 14:04:07 EDT
I see something similar in Chrome going from 1 topic directly to the next within a minute or 2 using the Search.
Comment 3 Matthew Casperson 2013-07-24 18:42:21 EDT
I saw this going to the search screen.

Thu Jul 25 08:40:48 GMT+1000 2013 org.jboss.pressgang.ccms.ui.client.local.App
SEVERE: (TypeError) : Object SearchTagsFieldsAndFiltersView has no method 'EW' 0.js:838
Thu Jul 25 08:40:48 GMT+1000 2013 org.jboss.pressgang.ccms.ui.client.local.App
SEVERE: Unknown.cX(StackTraceCreator.java:174)
Unknown.kNb(StackTraceCreator.java:508)
Unknown.GV(Exceptions.java:29)
Unknown.mic(HistoryImpl.java:40)
Unknown.anonymous(HistoryImplTimer.java:45)
Unknown.MNb(Impl.java:189)
Unknown.UNb(Impl.java:243)
Unknown.anonymous(Impl.java:70)
Unknown.anonymous(HistoryImplTimer.java:50)
Comment 4 sgilda 2013-07-24 19:59:09 EDT
HI Matt, just to let you know, Alex Dellapenta has seen the same problem.

And yes, it always happens going to a search of one type or another.
Comment 5 Lee Newson 2013-07-31 23:50:58 EDT
*** Bug 990809 has been marked as a duplicate of this bug. ***
Comment 6 Matthew Casperson 2013-08-15 22:50:06 EDT
This may have been because there were two HTML5 message listeners (the rendered view and the revisions view), and they were picking up each others messages.

I've uploaded build 201308161246 to the dev server, and will see if this has fixed the issue.
Comment 7 sgilda 2013-08-16 07:43:57 EDT
Thanks Matt. I'll let you know if I see it again.
Comment 8 Matthew Casperson 2013-08-18 20:32:53 EDT
Just saw the exception again this morning, so this has not fixed the issue.
Comment 9 sgilda 2013-08-18 20:55:02 EDT
I meant to tell you I didn't see it all day on Friday, so I thought it might be fixed. Sorry.
Comment 10 Matthew Casperson 2013-08-22 21:15:55 EDT
Exceptions.java is present in every stack trace I have seen, and it is part of the com.google.inject.internal package. 

After some double checking I found there were two instances where com.google.inject.Inject was used instead of javax.inject.Inject, which I have fixed up.

I'll upload a new version to the dev server and see if this fixes the issue.
Comment 11 Matthew Casperson 2013-08-22 22:09:49 EDT
Nope, that didn't fix it.
Comment 12 Lee Newson 2014-06-12 21:10:39 EDT
Marking this as CLOSED as I can no longer replicate it. Feel free to re-open it if it occurs again.
Comment 13 sgilda 2014-06-12 22:51:00 EDT
Hi Lee, that's fine by me. I only saw it for a short time. I'm sure it was fixed.

Note You need to log in before you can comment on or make changes to this bug.