Bug 984662 - vtk 6.0.0 support
vtk 6.0.0 support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pcl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Mattes
Fedora Extras Quality Assurance
https://github.com/PointCloudLibrary/...
: Reopened
Depends On:
Blocks: 987050 993457
  Show dependency treegraph
 
Reported: 2013-07-15 12:14 EDT by Orion Poplawski
Modified: 2013-09-12 15:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 15:51:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2013-07-15 12:14:59 EDT
Description of problem:

pcl 1.6.0 does not build against vtk 6.0.0.  I've checked in the beginnings of a patch to try to support it, but it is incomplete and perhaps not correct.

Upstream seems to be at least aware of changes in vtk 6, but I'm not aware of a development branch targeting it.

Version-Release number of selected component (if applicable):
1.6.0
Comment 1 Tim Niemueller 2013-07-15 15:21:13 EDT
Please report and get this fixed upstream, that's out of the scope of packaging.
Comment 2 Orion Poplawski 2013-07-22 11:28:14 EDT
Filed upstream.  I would like to keep this open though for tracking purposes if that is okay with you.
Comment 3 Rich Mattes 2013-08-21 21:35:40 EDT
I just pushed a patch that lets pcl 1.7.0 build against vtk 6.0.0 (currently in rawhide.)  I still need a review of the metslib package before I can kick off a build of pcl.
Comment 4 Orion Poplawski 2013-09-09 23:55:59 EDT
Upstream appears to have merged in a fix:

https://github.com/PointCloudLibrary/pcl/pull/218
Comment 5 Rich Mattes 2013-09-12 15:51:18 EDT
I saw that, but I don't think they've merged it yet.  I left a comment on the pull request about some missing functionality, and got a working version into the fedora pcl package.  I'll keep an eye on the upstream pull request and incorporate any new changes into the current fedora patch.

Note You need to log in before you can comment on or make changes to this bug.