Bug 984665 - java.lang.ClassCircularityError: org/kie/api/definition/type/Role after adding EVENT role to Data object
java.lang.ClassCircularityError: org/kie/api/definition/type/Role after addin...
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER2
: 6.0.0
Assigned To: Walter Medvedeo
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 12:20 EDT by Jiri Locker
Modified: 2014-08-06 16:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:16:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (24.08 KB, text/plain)
2013-07-15 12:20 EDT, Jiri Locker
no flags Details

  None (edit)
Description Jiri Locker 2013-07-15 12:20:54 EDT
Created attachment 773822 [details]
server.log

Description of problem:
It is possible to add "Event" role to a data object in data modeler and save it successfully. After that when opening any rule, an exception is printed into server log and the rule either doesn't open or opens a blank tab.

Version-Release number of selected component (if applicable):
DR6

How reproducible:


Steps to Reproduce:
1. open Data Modeler in mortgages project
2. add Event role to any data object and save the model
3. try opening Dummy rule or some other asset

Actual results:
The rule doesn't open, exception is thrown.

Expected results:
No exception.

Additional info:
Attached exception stack trace.
Comment 1 manstis 2013-07-17 05:24:46 EDT
Walter, I believe this has been fixed for CR1, but please confirm and set this Bugzilla to MODIFIED (if it is now resolved). Thanks, Mike
Comment 2 Jiri Locker 2013-07-30 07:17:29 EDT
Yes, it seems to be fixed in CR1.
Comment 3 Jiri Locker 2013-09-12 12:28:55 EDT
Fix verified in ER2.

Note You need to log in before you can comment on or make changes to this bug.