Bug 984737 - usability: webadmin difficulty in assigning client ip, no gateway possible
usability: webadmin difficulty in assigning client ip, no gateway possible
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.2
Unspecified Linux
high Severity medium
: ---
: 3.5.0
Assigned To: Lior Vernia
Meni Yakove
network
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 16:30 EDT by jas
Modified: 2016-02-10 14:36 EST (History)
8 users (show)

See Also:
Fixed In Version: ovirt-3.5.0-beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-17 08:25:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mock-up: actions drop-down menu (40.59 KB, image/png)
2013-08-22 12:41 EDT, Einav Cohen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 29764 master MERGED webadmin: Always display edit icon in Setup Networks Never
oVirt gerrit 29994 ovirt-engine-3.5 MERGED webadmin: Always display edit icon in Setup Networks Never

  None (edit)
Description jas 2013-07-15 16:30:59 EDT
Description of problem:

When using the webadmin, it is easy to assign the NICs on the node to logical networks.  However, after spending a significant amount of time trying to figure out how to actually assign an IP and subnet mask to the adapter, I was stumped!   It turns out that to assign boot protocol/IP/subnet mask, you must hover over  not the interface, but the logical network, and only when the tiny pencil appears and you click on it, can you further configure the interface.  I missed that.  Maybe a chance could be made to make it more obvious.  This could be as simple as a bubble/textual message in the configuration box that tells you what to do to edit the interface configuration.

In addition, while I can assign IP and subnet mask, I can't assign gateway when using a static IP.  This means I either have to mount the filesystem on the node read-write, and make the change manually, or use DHCP.  Why no option for gateway?
Comment 1 Dan Kenigsberg 2013-07-21 17:58:08 EDT
oVirt-3.3 is going to host the ability to set multiple gateways per host. (Currently, you can sent only the gateway for the management network.)

boot protocol/IP/subnet are intentionally network-related configurables, not per interface. However, it would be nicer if that's clearer and easier to reach.
Comment 2 Lior Vernia 2013-08-04 15:53:02 EDT
Thank you Jason for the input, I see how finding the edit icon could prove difficult. I'll discuss this with our UX people and see what they advise.
Comment 3 Lior Vernia 2013-08-20 08:34:34 EDT
Having talked to a designer, the proposed solution is to still make the edit functionality available only upon hovering, but rather than the tiny pencil we'll redesign the tooltip frame to include a clear "Edit" command, which should make it more noticeable and intuitive. The plan is to also add the edit command as an option to the right click menu.

I'll also remark that it makes sense to hover over the network and not the interface - these properties belong to the network rather than the interface. Imagine the case where you have several networks (presumably VLAN-tagged) on one physical interface - they should have different IP addresses, etc.
Comment 4 jas 2013-08-20 08:41:54 EDT
Thanks! That makes a lot of sense. :) I look forward to experimenting with oVirt 3.3.
Comment 5 Einav Cohen 2013-08-22 12:39:03 EDT
(In reply to jas from comment #4)
> Thanks! That makes a lot of sense. :) I look forward to experimenting with
> oVirt 3.3.

I think that this solution doesn't fully address your concern regarding what you have written in the description ("you must hover over *not the interface, but the logical network*, and only when the tiny pencil appears) - you had trouble finding the edit option to begin with, as it was "hidden" in a hovering functionality. replacing the content that appears when hovering won't really solve that issue.
Comment 6 Einav Cohen 2013-08-22 12:41:06 EDT
Created attachment 789272 [details]
mock-up: actions drop-down menu

the attached solution (from Malini) addresses the problem of finding the edit functionality to begin with, as it is always displayed, rather than hidden in a panel that appears only upon hover.
Comment 7 Lior Vernia 2013-11-10 05:43:17 EST
Have we arrived at a single more-or-less agreed-upon solution following all the mailing list discussions?
Comment 8 Itamar Heim 2014-01-12 03:43:02 EST
setting target release to current version for consideration and review. please do not push non-RFE bugs to an undefined target release to make sure bugs are reviewed for relevancy, fix, closure, etc.
Comment 9 mrao 2014-01-28 16:23:13 EST
(In reply to Lior Vernia from comment #7)
> Have we arrived at a single more-or-less agreed-upon solution following all
> the mailing list discussions?

I think there are 2 underlying issues that have been pointed out in this bug - 1. It is not obvious to the user that they have to go edit the logical network to further configure the connection. In the user's mind, they are thinking of configuring the NIC. So, I think we need to add an info bubble there to help guide users to the Logical network edit dialog or we need to move fields to the Edit NIC if it makes sense to do so.

2. With regard to the discoverability of the edit icon that is currently available upon hover, we have improved the location of where it appears and we can test to see if this is still an issue in terms of discoverability. We have also attached a mockup for how we could display the edit action persistently but this should be a last resort option since the network boxes have quite a few visual markings on them already.
Comment 10 Lior Vernia 2014-03-03 08:08:18 EST
New design of the dialog set to be implemented, should solve this issue.
Comment 11 mrao 2014-05-28 17:36:37 EDT
(In reply to mrao from comment #9)
> (In reply to Lior Vernia from comment #7)
> > Have we arrived at a single more-or-less agreed-upon solution following all
> > the mailing list discussions?
> 
> I think there are 2 underlying issues that have been pointed out in this bug
> - 1. It is not obvious to the user that they have to go edit the logical
> network to further configure the connection. In the user's mind, they are
> thinking of configuring the NIC. So, I think we need to add an info bubble
> there to help guide users to the Logical network edit dialog or we need to
> move fields to the Edit NIC if it makes sense to do so.
> 
> 2. With regard to the discoverability of the edit icon that is currently
> available upon hover, we have improved the location of where it appears and
> we can test to see if this is still an issue in terms of discoverability. We
> have also attached a mockup for how we could display the edit action
> persistently but this should be a last resort option since the network boxes
> have quite a few visual markings on them already.


A mini-usability test around the discoverability of the pencil icon on NICs and Logical networks in the Setup Host networks dialog was conducted. The live instance was used as one alternative ( pencil shows on hover and persists on drag but does not persist on click/ select) and a quick Axure prototype was created to show a subtle alternative ( Pencil shows on hover and stays in display on select and drag). 

A note taker and I sat in a prominent but quiet(er) area of the cafeteria and talked to 15 people who took the test in exchange for PatternFly T-Shirts. We showed the live instance and the proptotype alternately for every other participant. 

The test began with a basic introduction to the setup networks dialog as a place where user connects 2 entities via drag and drop and we reassured them that for the task there was no networking knowledge or previous experience with Ovirt needed. The participant was pointed to a network that was already associated with a NIC and asked to change some parameters for it. 

FINDINGS SUMMARY

* There was no significant difference between the live instance and the prototype. The task in the test was so small and specific , that the user did not spend a lot of time on any network or NIC in a selected state. 

* When asked for their opinion, almost all participants preferred having the Edit icon display persistently rather than hover. HOWEVER, no participant failed the task of finding the edit icon and they discovered it within 3-5 secs of the start of the task. So, the icon is definitely discoverable. The overwhelming preference for the edit icon to be displayed persistently has to be seen in the light of the fact that the participants were focused 100% on the task of editing the network and therefore looking for an edit icon in this usability test. The dialog was otherwise not necessarily meaningful to them and they did not have the main motivation of the real users of this dialog - to make network connections for this specific host. Given this broader and more important purpose, the persistent display of the edit icon is less important said, "I have heard people say that a discoverable control can be confusing... but to  me it is such a common UI element now that it feels like you are saying you need to include a tutorial for how to use a mouse!" 

* Other findings besides the main discoverability aspect -

-- People thought the tooltip ( which displays right below the network name aligned to the left edge) was a cascading form/ drop down menu and that they could edit values in there. We should adjust the placement/ location so that it looks more like a tooltip and less like a form that allows inline editing. 

-- The borders around the network role icons made people think of them as buttons and so they looked for the edit icon next to them. Since these are informational icons, we should eliminate the borders around them.

-- The Physical and the logical entities should probably be further differentiated  - Participant 11 said they look too much alike.

BOTTOM LINE

The usability test validates that the edit icon display on hover is discoverable and an effective solution. There is no need to persist its display in the context of setup networks where the primary goal is not to edit but connect networks and NICs and where the view is complex with many icons already.
Comment 12 Lior Vernia 2014-05-29 03:59:30 EDT
Thanks for this Malini. Since we're already discussing a redesign of the Setup Networks dialog we should keep these findings in mind (e.g. remove border from role icons, have edit icon on a different theme from the role icons), but this specific bug can probably be closed.
Comment 13 Lior Vernia 2014-07-13 08:29:04 EDT
Over-automation.
Comment 14 Meni Yakove 2014-07-24 03:24:52 EDT
ovirt-engine-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
Comment 15 Sandro Bonazzola 2014-10-17 08:25:05 EDT
oVirt 3.5 has been released and should include the fix for this issue.

Note You need to log in before you can comment on or make changes to this bug.