Bug 984749 - Removing default info for system/distributor at Organization level is unsuccessful
Removing default info for system/distributor at Organization level is unsucce...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Adam Price
sthirugn@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 17:17 EDT by Apurva Bhole
Modified: 2014-07-21 14:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-30 13:52:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Apurva Bhole 2013-07-15 17:17:06 EDT
Description of problem:
Removing default info for system/distributor at Organization level gives a success message but does not remove the custom info attached to the corresponding systems/distributors

How reproducible:
everytime

Steps to Reproduce:

1. Create Org
> org create --name newOrg
2. Create distributor 
> distributor create --name newDistributor --org newOrg
3. Attach default custom info to the distributors of newOrg
> org default_info add --name newOrg --keyname newKey --type distributor
> org default_info apply --name newOrg --type distributor
4. The default custom info shows up for the distributor 
> distributor info --name newDistributor --org newOrg
5. Remove the default info
> org default_info remove --name newOrg --keyname newKey --type distributor
> org default_info apply --name newOrg --type distributor
6. The default custom info is still present
> distributor info --name newDistributor --org newOrg

Actual results:
The default info is not removed from the distributors in context

Expected results:
The default info that was removed should not be present
Comment 1 RHEL Product and Program Management 2013-09-17 00:22:57 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 sthirugn@redhat.com 2014-04-30 13:52:14 EDT
Custom Distributor not relevant to Sat 6 now.

Note You need to log in before you can comment on or make changes to this bug.