Bug 984838 - [abrt] java-1.8.0-openjdk-1.8.0.0-0.7.b89.fc19: os::abort(bool): Process /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.0.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
[abrt] java-1.8.0-openjdk-1.8.0.0-0.7.b89.fc19: os::abort(bool): Process /usr...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
abrt_hash:b3fda792d5c00210b5911d9aee1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 03:33 EDT by Stef Walter
Modified: 2013-07-25 11:16 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 11:16:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (94.31 KB, text/plain)
2013-07-16 03:34 EDT, Stef Walter
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-16 03:34 EDT, Stef Walter
no flags Details
File: core_backtrace (1.39 KB, text/plain)
2013-07-16 03:34 EDT, Stef Walter
no flags Details
File: dso_list (14.75 KB, text/plain)
2013-07-16 03:34 EDT, Stef Walter
no flags Details
File: environ (2.44 KB, text/plain)
2013-07-16 03:34 EDT, Stef Walter
no flags Details
File: hs_err.log (136.56 KB, text/plain)
2013-07-16 03:34 EDT, Stef Walter
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-16 03:34 EDT, Stef Walter
no flags Details
File: maps (101.45 KB, text/plain)
2013-07-16 03:34 EDT, Stef Walter
no flags Details
File: open_fds (14.01 KB, text/plain)
2013-07-16 03:34 EDT, Stef Walter
no flags Details
File: proc_pid_status (932 bytes, text/plain)
2013-07-16 03:34 EDT, Stef Walter
no flags Details
File: var_log_messages (380 bytes, text/plain)
2013-07-16 03:34 EDT, Stef Walter
no flags Details

  None (edit)
Description Stef Walter 2013-07-16 03:33:57 EDT
Version-Release number of selected component:
java-1.8.0-openjdk-1.8.0.0-0.7.b89.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 3
cmdline:        /usr/bin/java -Dosgi.requiredJavaVersion=1.6 -XX:MaxPermSize=256m -Xms40m -Xmx384m -jar /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar -os linux -ws gtk -arch x86_64 -showsplash -launcher /opt/eclipse/eclipse -name Eclipse --launcher.library /opt/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505/eclipse_1407.so -startup /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar --launcher.overrideVmargs -exitdata 59970017 -product org.eclipse.epp.package.linuxtools.product -vm /usr/bin/java -vmargs -Dosgi.requiredJavaVersion=1.6 -XX:MaxPermSize=256m -Xms40m -Xmx384m -jar /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
crash_function: os::abort(bool)
executable:     /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.0.x86_64/jre/bin/java
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (7 frames)
 #2 os::abort(bool) at /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.0.x86_64/jre/lib/amd64/server/libjvm.so
 #3 VMError::report_and_die() at /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.0.x86_64/jre/lib/amd64/server/libjvm.so
 #4 JVM_handle_linux_signal at /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.0.x86_64/jre/lib/amd64/server/libjvm.so
 #5 signalHandler(int, siginfo_t*, void*) at /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.0.x86_64/jre/lib/amd64/server/libjvm.so
 #7 soup_session_feature_detach at soup-session-feature.c:141
 #8 Java_org_eclipse_swt_internal_webkit_WebKitGTK__1soup_1session_1feature_1detach at /opt/eclipse/configuration/org.eclipse.osgi/bundles/351/1/.cp/libswt-webkit-gtk-3740.so
 #9 ??
Comment 1 Stef Walter 2013-07-16 03:34:02 EDT
Created attachment 774040 [details]
File: backtrace
Comment 2 Stef Walter 2013-07-16 03:34:05 EDT
Created attachment 774041 [details]
File: cgroup
Comment 3 Stef Walter 2013-07-16 03:34:09 EDT
Created attachment 774042 [details]
File: core_backtrace
Comment 4 Stef Walter 2013-07-16 03:34:20 EDT
Created attachment 774043 [details]
File: dso_list
Comment 5 Stef Walter 2013-07-16 03:34:23 EDT
Created attachment 774044 [details]
File: environ
Comment 6 Stef Walter 2013-07-16 03:34:28 EDT
Created attachment 774045 [details]
File: hs_err.log
Comment 7 Stef Walter 2013-07-16 03:34:33 EDT
Created attachment 774046 [details]
File: limits
Comment 8 Stef Walter 2013-07-16 03:34:39 EDT
Created attachment 774048 [details]
File: maps
Comment 9 Stef Walter 2013-07-16 03:34:43 EDT
Created attachment 774049 [details]
File: open_fds
Comment 10 Stef Walter 2013-07-16 03:34:46 EDT
Created attachment 774050 [details]
File: proc_pid_status
Comment 11 Stef Walter 2013-07-16 03:34:50 EDT
Created attachment 774051 [details]
File: var_log_messages
Comment 12 Deepak Bhole 2013-07-16 09:21:09 EDT
Originated in Eclipse JNI code. Re-assigning component.

It sounds like you are using an external Eclipse version by the way, which may not be supported (I'll let the Eclipse engineers confirm that):

/opt/eclipse/configuration/org.eclipse.osgi/bundles/351/1/.cp/libswt-webkit-gtk-3740.so
Comment 13 Alexander Kurtakov 2013-07-25 11:16:54 EDT
This bug is reported with older version of Eclipse not the one from Fedora.
The problem is that Fedora ships with new webkit which is not compatible with old swt. Please either use eclipse as shipped with Fedora 19 or download eclipse kepler from eclipse.org to fix the problem. We have fixed the problem with current webkit both in Fedora and upstream but users need to update their eclipse installations.

Note You need to log in before you can comment on or make changes to this bug.