Bug 984934 - Direct access to parallel port from the VM doesn't actually work.
Direct access to parallel port from the VM doesn't actually work.
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 08:03 EDT by Alex Trusty
Modified: 2014-01-14 06:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-14 06:46:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Trusty 2013-07-16 08:03:52 EDT
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0
Build Identifier: 

A KVM virtual machine is beeing set up using virt-manager, where a parallel port is to be forwarded to the host system parallel port device /dev/parport0.
It results in the following command line:

/usr/bin/kvm-spice -S -M pc-1.1 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name Digiton -uuid 117540b7-4bd8-b574-0fcc-cec1a51188e3 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/Digiton.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime -no-shutdown -boot c -drive file=/home/alext/sdb.raw,if=none,id=drive-ide0-0-0,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,fd=18,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:f6:63:28,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev tty,id=charparallel0,path=/dev/parport0 -device isa-parallel,chardev=charparallel0,id=parallel0 -usb -device usb-tablet,id=input0 -vnc 127.0.0.1:0 -vga cirrus -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5



Reproducible: Always

Steps to Reproduce:
1.Set up a VM using virt-manager
2.Run it

Actual Results:  
Parallel port isn't mapped, because of the wrong parameters:

-chardev tty,id=charparallel0,path=/dev/parport0 -device isa-parallel,chardev=charparallel0,id=parallel0

Expected Results:  
With the parameters:
-chardev parport,id=charparallel0,path=/dev/parport0 -device isa-parallel,chardev=charparallel0,id=parallel0 

everything works as expected.

Package: libvirt0                        
State: installed
Automatically installed: yes
Version: 0.9.8-2ubuntu17.10

Package: virt-manager                    
State: installed
Automatically installed: no
Version: 0.9.1-1ubuntu5.1
Comment 1 Alex Trusty 2014-01-14 06:46:41 EST
It seems to be fixed now:

/usr/bin/kvm-spice -S -M pc-1.1 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name Digiton -uuid 117540b7-4bd8-b574-0fcc-cec1a51188e3 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/Digiton.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime -no-shutdown -boot c -drive file=/home/alext/sdb.raw,if=none,id=drive-ide0-0-0,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,fd=19,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:f6:63:28,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev parport,id=charparallel0,path=/dev/parport0 -device isa-parallel,chardev=charparallel0,id=parallel0 -usb -device usb-tablet,id=input0 -vnc 127.0.0.1:0 -vga cirrus -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -incoming fd:16 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5
Comment 2 Alex Trusty 2014-01-14 06:47:57 EST
Thank you :)

Note You need to log in before you can comment on or make changes to this bug.