Bug 984944 - cppcheck found new leak in ksh
cppcheck found new leak in ksh
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ksh (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michal Hlavinka
Martin Kyral
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 08:34 EDT by Martin Kyral
Modified: 2013-09-30 20:26 EDT (History)
1 user (show)

See Also:
Fixed In Version: ksh-20100621-18.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 20:26:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kyral 2013-07-16 08:34:31 EDT
Description of problem:
cppcheck-diff.sh found new issue in ksh-20100621-17.el5 compared to ksh-20100621-12.el5:

src/cmd/ksh93/sh/subshell.c:204,error,memleak,Memory leak: trap

Version-Release number of selected component (if applicable):
ksh-20100621-17.el5

How reproducible:


Steps to Reproduce:
1. install 
2. cd /usr/src/redhat/BUILD/ksh-20100621/
3. cppcheck --template "{file}:{line},{severity},{id},{message}" -i test -i tests -i testsuite -j 4 --quiet . 2>&1


Actual results:
memleak src/cmd/ksh93/sh/subshell.c:204,error,memleak,Memory leak: trap is found
Comment 1 RHEL Product and Program Management 2013-07-16 09:49:37 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 errata-xmlrpc 2013-09-30 20:26:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1351.html

Note You need to log in before you can comment on or make changes to this bug.