Bug 984954 - Disk actuall size is twice than the virtual (and real) size
Disk actuall size is twice than the virtual (and real) size
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Nobody's working on this, feel free to take it
Pavel Stehlik
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 08:55 EDT by Meital Bourvine
Modified: 2016-02-10 14:57 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 04:21:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (1.58 MB, application/x-gzip)
2013-07-16 08:55 EDT, Meital Bourvine
no flags Details

  None (edit)
Description Meital Bourvine 2013-07-16 08:55:11 EDT
Created attachment 774218 [details]
logs

Description of problem:
Disk actuall size is twice than the virtual (and real) size.

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.6.master.el6ev.noarch

How reproducible:
Not 100%

Steps to Reproduce: On a block pool with 1 host and 2 storage domains:
1. Create a vm with 2 disks (50g each)
2. Check actual size of both disks is 50g
3. Create a snapshot
4. Check actual size of both disks is 100g
5. Also try to move (migrate) one of the disks to a storage domain with ~90g free, and see that it fails due to not enogh space.

Actual results:
The actuall disk size shows 100g.

Expected results:
The actuall disk size will show the currect value (50g).
Comment 1 Maor 2013-07-22 07:24:14 EDT
virtual size indicates the size that the OS using when read/write the disk (should be 50GB).
actual size should indicates the size that the disk occupies in the storage including its snapshots, since the disk is preallocated (as I saw in the logs) and it had a snapshot, its actual size should be 100GB
Comment 2 Sean Cohen 2013-07-23 04:21:27 EDT
Based on comment 1, closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.