Bug 985009 - p11-kit: p11_extract_info_load_filter uninitialized result variable
p11-kit: p11_extract_info_load_filter uninitialized result variable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: p11-kit (Show other bugs)
7.1
Unspecified Unspecified
low Severity low
: rc
: 7.1
Assigned To: Stef Walter
Aleš Mareček
:
Depends On:
Blocks: 1151118 983512
  Show dependency treegraph
 
Reported: 2013-07-16 10:44 EDT by Florian Weimer
Modified: 2015-03-05 02:54 EST (History)
2 users (show)

See Also:
Fixed In Version: p11-kit-0.20.4-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1151118 (view as bug list)
Environment:
Last Closed: 2015-03-05 02:54:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iter: Document guarantees for filter matches argumet (1.11 KB, patch)
2013-07-16 12:24 EDT, Stef Walter
no flags Details | Diff

  None (edit)
Description Florian Weimer 2013-07-16 10:44:44 EDT
tools/extract-info.c:p11_extract_info_load_filter() does not always write to *matches on success.  (The only caller, call_all_filters(), initializes *matches to CK_TRUE, though.)
Comment 1 Stef Walter 2013-07-16 10:58:18 EDT
Hmmm, these are meant to be callbacks, and part of the ABI is that *matches is set to CK_TRUE when the callback is called. 

I'll document this, but I don't think this is a problem.
Comment 3 Stef Walter 2013-07-16 12:24:59 EDT
Created attachment 774405 [details]
iter: Document guarantees for filter matches argumet

The matches argument is always initialized to CK_TRUE when a filter
is called, and it's up to filters to set it to CK_FALSE. Filters
don't need to set to CK_TRUE.
Comment 5 Stef Walter 2013-07-18 10:15:57 EDT
Pushed patch to p11-kit git master, and released in development version 0.19.2.
Comment 11 errata-xmlrpc 2015-03-05 02:54:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0339.html

Note You need to log in before you can comment on or make changes to this bug.