This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 985024 - Scalable App will show HAproxy Version page instead of maintenance page
Scalable App will show HAproxy Version page instead of maintenance page
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
All All
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
: SupportQuestion
: 1001760 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 11:14 EDT by Nick Harvey
Modified: 2013-09-19 12:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 12:46:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (187.30 KB, image/png)
2013-07-16 11:15 EDT, Nick Harvey
no flags Details

  None (edit)
Description Nick Harvey 2013-07-16 11:14:12 EDT
Description of problem: When pushing code to a scalable app, instead of a the maintenance page users will see a HAproxy page. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a PHP app
2. Make it Scalable
3. Create a file and push it 

Actual results:
User will see HAproxy page instead of maintenance page

Expected results:
Maintenance page should be presented during application downtime


Additional info:
Comment 1 Nick Harvey 2013-07-16 11:15:03 EDT
Created attachment 774371 [details]
Screenshot
Comment 2 Mrunal Patel 2013-07-16 14:46:56 EDT
Could you provide details about what file are you adding?
Also, could you check the logs on the gear?
Comment 3 Mrunal Patel 2013-09-09 11:08:14 EDT
*** Bug 1001760 has been marked as a duplicate of this bug. ***
Comment 5 openshift-github-bot 2013-09-10 21:21:43 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/477c7058477c5fbcf26276165f53a0587cdef956
Bug 985024: Remove haproxy status page as the backup page.
Comment 6 Meng Bo 2013-09-11 06:49:28 EDT
Verified on devenv_3772, during gear git push, visit the gear home page will show 503 page.

Visit the /haproxy-status page will get the gear status.

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.