Bug 985032 - Fail to start - Error: Schema org.gnome.shell.extensions.cpu-temperature could not be found
Fail to start - Error: Schema org.gnome.shell.extensions.cpu-temperature coul...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-cpu-temperature (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 11:28 EDT by Hin-Tak Leung
Modified: 2013-11-22 02:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-22 02:42:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2013-07-16 11:28:45 EDT
Description of problem:
The gnome-shell-extension-cpu-temperature extension fails to load.( See work around at the end.)

Error: Schema org.gnome.shell.extensions.cpu-temperature could not be found for extension temperature@xtranophilist. Please check your 
installation.

Stack trace:
  getSettings()@/usr/share/gnome-shell/extensions/temperature@xtranophilist/convenience.js:64
  ()@/usr/share/gnome-shell/extensions/temperature@xtranophilist/prefs.js:28
  wrapper()@/usr/share/gjs-1.0/lang.js:213
  buildPrefsWidget()@/usr/share/gnome-shell/extensions/temperature@xtranophilist/prefs.js:119
  ("temperature@xtranophilist")@/usr/share/gnome-shell/js/extensionPrefs/main.js:100
  wrapper("temperature@xtranophilist")@/usr/share/gjs-1.0/lang.js:213
  ([object GObject_Object])@/usr/share/gnome-shell/js/extensionPrefs/main.js:119
  wrapper([object GObject_Object])@/usr/share/gjs-1.0/lang.js:213
  main([object Array])@/usr/share/gnome-shell/js/extensionPrefs/main.js:276
  @<command line>:1
  


Version-Release number of selected component (if applicable):
gnome-shell-extension-cpu-temperature-1.1-1.fc19.noarch

How reproducible:
Always

Steps to Reproduce:
1. Just configure it and try to load it.
2. watch the above message in gnome-shell's log
3.

Actual results:
Fail to load

Expected results:
shows cpu temperature in top panel.

Additional info:

This seems to be a simple mis-packaging. copying 
schemas/org.gnome.shell.extensions.cpu-temperature.gschema.xml
from the upstream repository to 
/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.cpu-temperature.gschema.xml
where all the other schemas are, fixes the problem.

upstream repository:

git://github.com/xtranophilist/gnome-shell-extension-cpu-temperature.git
Comment 1 Hin-Tak Leung 2013-07-16 11:32:35 EDT
Oh, you also need to do this: 

/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas &> /dev/null

for the newly added schema to take effect. (tips from post-install scripts in rpms of other extensions with schema).
Comment 2 Fabian Affolter 2013-11-22 02:42:49 EST
Package is retired.

Note You need to log in before you can comment on or make changes to this bug.