Bug 985071 - [abrt] youtube-dl-2013.05.14-1.fc19: __init__.py:563:_real_main:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 54: ordinal not in range(128)
[abrt] youtube-dl-2013.05.14-1.fc19: __init__.py:563:_real_main:UnicodeDecode...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: youtube-dl (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
abrt_hash:b49398217c11bc68614acd1e5ea...
:
: 995733 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 13:29 EDT by Alejandro
Modified: 2014-09-01 00:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-01 00:42:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.24 KB, text/plain)
2013-07-16 13:29 EDT, Alejandro
no flags Details
File: core_backtrace (358 bytes, text/plain)
2013-07-16 13:29 EDT, Alejandro
no flags Details
File: environ (10.24 KB, text/plain)
2013-07-16 13:29 EDT, Alejandro
no flags Details

  None (edit)
Description Alejandro 2013-07-16 13:29:09 EDT
Description of problem:
command:
youtube-dl -t -v -c -a list.dl

exit:
[debug] System config: ['--prefer-free-formats']
[debug] User config: []
[debug] Command-line args: ['-t', '-v', '-c', '-a', 'list.dl']
[debug] youtube-dl version 2013.07.02
Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/bin/youtube-dl/__main__.py", line 18, in <module>
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 634, in main
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 595, in _real_main
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 54: ordinal not in range(128)

list.dl content:
http://www.youtube.com/watch?v=S-KHU4eKoEM
http://www.youtube.com/watch?v=5bHPKU4ybHY
http://www.youtube.com/playlist?list=PLA567CE235D39FA84
http://www.youtube.com/watch?v=zLW8Fd14WCM

Version-Release number of selected component:
youtube-dl-2013.05.14-1.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        python /usr/bin/youtube-dl -t -v -c -a list.dl
dso_list:       python-libs-2.7.5-1.fc19.x86_64
executable:     /usr/bin/youtube-dl
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            1000
Comment 1 Alejandro 2013-07-16 13:29:17 EDT
Created attachment 774429 [details]
File: backtrace
Comment 2 Alejandro 2013-07-16 13:29:21 EDT
Created attachment 774430 [details]
File: core_backtrace
Comment 3 Alejandro 2013-07-16 13:29:26 EDT
Created attachment 774431 [details]
File: environ
Comment 4 Christopher Meng 2013-07-16 20:56:48 EDT
You were not using the latest version.

Please use yum to update.
Comment 5 Alejandro 2013-07-21 14:28:01 EDT
Thanks Christopher, but I use now the 2013-07-19 version and the problem persist.

Exit:

[debug] System config: ['--prefer-free-formats']
[debug] User config: []
[debug] Command-line args: ['-t', '-v', '-c', '-a', 'list.dl']
[debug] youtube-dl version 2013.07.19
Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/bin/youtube-dl/__main__.py", line 18, in <module>
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 637, in main
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 598, in _real_main
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 54: ordinal not in range(128)

I try to update with 'sudo youtube-dl -U' and 'yum update --enablerepo=updates-testing youtube-dl', but nothing.

PD: sorry for my english, is very bad =(
Comment 6 Michael Schwendt 2013-07-21 15:23:23 EDT
* The problem is clearly reproducible here with an even simpler test-case. The verbose output is broken, because it cannot cope with Fedora 19's release name "Schrödinger’s Cat":

$ rpm -q youtube-dl
youtube-dl-2013.07.12-1.fc19.noarch
$ youtube-dl -v
[debug] System config: ['--prefer-free-formats']
[debug] User config: []
[debug] Command-line args: ['-v']
[debug] youtube-dl version 2013.07.12
Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/bin/youtube-dl/__main__.py", line 18, in <module>
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 634, in main
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 595, in _real_main
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 54: ordinal not in range(128)

$ python
>>> import platform
>>> print platform.python_version()
2.7.5
>>> print platform.platform()
Linux-3.9.9-302.fc19.x86_64-x86_64-with-fedora-19-Schrödinger’s_Cat
>>> 


* Fedora pkg git contents need some cleanup. The source tarballs have been uploaded with the wrong fedpkg command:

$ cat sources 
139ffe39568318a5939edf05afbac4d0  youtube-dl-2013.05.14.tar.gz
6cb4ee904456d102d4f3edb68272ca50  youtube-dl-2013.05.23.tar.gz
83638449553afa6bedce40edc254d182  youtube-dl-2013.06.31.tar.gz
89f7959dec2a7e669887b509bb101358  youtube-dl-2013.07.02.tar.gz
17888031303b26437e5195df22697940  youtube-dl-2013.07.10.tar.gz
5549a8be5054eaf02470da8955b838a0  youtube-dl-2013.07.12.tar.gz
689d7d2507a0a452e53c2c40957220dc  youtube-dl-2013.07.17.1.tar.gz
Comment 7 Christopher Meng 2013-08-06 01:14:07 EDT
Need to be fixed by upstream.

I may open a pull request or an issue later.

sources file is fine IMO.
Comment 8 Michael Schwendt 2013-08-06 04:10:11 EDT
> Need to be fixed by upstream.

Temporarily dropping the platform.platform() call would be an easy fix, since it's Fedora's special distname that causes this issues.


> sources file is fine IMO.

Why would you say that?

You need to use "fedpkg new-sources TARBALL" when uploading a new archive. Instead, you've used "fedpkg upload TARBALL" to _append_ archives to the file, so they've accumulated over time, and now the sources files lists old archives which are not needed anymore for the package.

https://fedoraproject.org/wiki/Package_update_HOWTO#Build_a_package_for_Rawhide
Comment 9 Michael Schwendt 2013-08-10 17:39:28 EDT
*** Bug 995733 has been marked as a duplicate of this bug. ***
Comment 10 Philipp Hagemeister 2014-08-31 19:02:34 EDT
This has been fixed upstream; I can't reproduce it with either upstream youtube-dl nor the one shipped with F19.1.

Note You need to log in before you can comment on or make changes to this bug.