Bug 98513 - Source package contains pre-compiled binaries, will not work on non-i386!
Source package contains pre-compiled binaries, will not work on non-i386!
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rhpl (Show other bugs)
1.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-03 00:53 EDT by Aleksey Nogin
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-03 01:07:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2003-07-03 00:53:15 EDT
It seems that the x86_64 version of the rhpl package in current Rawhide was
compiled against non-64bit glibc:

# rpm -Uvh rhpl-0.105.1-2.x86_64.rpm
error: Failed dependencies:
        libc.so.6 is needed by rhpl-0.105.1-2
        libc.so.6(GLIBC_2.0) is needed by rhpl-0.105.1-2
        libc.so.6(GLIBC_2.1.3) is needed by rhpl-0.105.1-2
        libc.so.6(GLIBC_2.2) is needed by rhpl-0.105.1-2
# rpm -q --provides glibc | grep libc.so
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.2.6)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libc.so.6(GLIBC_2.3.2)(64bit)
libc.so.6(GLIBC_2.3.3)(64bit)
libc.so.6(GLIBC_PRIVATE)(64bit)
# rpm -Uvh --nodeps rhpl-0.105.1-2.x86_64.rpm
Preparing...                ########################################### [100%]
   1:rhpl                   ########################################### [100%]
# ldd /usr/lib64/python2.2/site-packages/rhpl/_translate.so
/usr/bin/ldd: line 1: /lib/ld-linux.so.2: No such file or directory
ldd: /lib/ld-linux.so.2 exited with unknown exit code (127)
# ls -l /lib*/ld-linux*
lrwxrwxrwx    1 root     root           11 Jun 27 10:30
/lib64/ld-linux-x86-64.so.2 -> ld-2.3.2.so
Comment 1 Aleksey Nogin 2003-07-03 01:03:37 EDT
The problem seems to be that the source package _already_ contains the *.so, and
those are not being rebuilt at all!!!!!!!

P.S. Also, the source tarball seems to contain tarballs for old versions of
rhpl, which waists space. The source package also contains a lot of other just
as well (such as build directories).

# tar -tzvf SOURCES/rhpl-0.105.1.tar.gz|egrep '\.(s*o|tar)'

-rw-rw-r-- katzj/katzj   32956 2003-04-23 07:57:01
rhpl-0.105.1/src/ethtool/build/temp.linux-i686-2.2/ethtool.o
-rw-rw-r-- katzj/katzj   60612 2002-12-12 13:57:23
rhpl-0.105.1/src/ethtool/build/temp.linux-i686-2.2/iwlib.o
-rwxrwxr-x katzj/katzj   92449 2002-12-13 14:30:12
rhpl-0.105.1/src/ethtool/build/lib.linux-i686-2.2/ethtool.so
-rwxrwxr-x katzj/katzj   78332 2003-04-23 07:57:02
rhpl-0.105.1/src/ethtool/ethtool.so
-rw-r--r-- katzj/katzj   22163 2003-01-31 12:26:17
rhpl-0.105.1/src/ethtool/ethtool.c.orig
-rw-rw-r-- katzj/katzj   42060 2002-12-12 13:57:21
rhpl-0.105.1/src/iconvmodule/build/temp.linux-i686-2.2/iconvmodule.o
-rwxrwxr-x katzj/katzj   38137 2002-12-13 14:30:12
rhpl-0.105.1/src/iconvmodule/build/lib.linux-i686-2.2/iconv.so
-rwxrwxr-x katzj/katzj   38137 2002-12-12 13:57:21
rhpl-0.105.1/src/iconvmodule/iconv.so
-rw-rw-r-- katzj/katzj     195 2002-05-22 15:12:44
rhpl-0.105.1/src/iconvmodule/Makefile.orig
-rw-rw-r-- katzj/katzj   49668 2002-12-12 13:57:18 rhpl-0.105.1/src/_diskutil.o
-rwxrwxr-x katzj/katzj   43418 2002-12-12 13:57:18 rhpl-0.105.1/src/_diskutil.so
-rw-rw-r-- katzj/katzj   11488 2003-04-23 07:56:59 rhpl-0.105.1/src/_translate.o
-rwxrwxr-x katzj/katzj   14976 2003-04-23 07:56:59 rhpl-0.105.1/src/_translate.so
-rw-rw-r-- katzj/katzj  433084 2003-02-24 17:40:49 rhpl-0.105.1/rhpl-0.93.tar.gz
-rw-rw-r-- katzj/katzj  435525 2003-04-17 22:00:10 rhpl-0.105.1/rhpl-0.97.tar.gz
-rw-rw-r-- katzj/katzj  435583 2003-04-21 14:52:37 rhpl-0.105.1/rhpl-0.98.tar.gz
-rw-rw-r-- katzj/katzj  435856 2003-04-23 20:07:09 rhpl-0.105.1/rhpl-0.98.1.tar.gz
-rw-rw-r-- katzj/katzj  446213 2003-05-23 09:51:58 rhpl-0.105.1/rhpl-0.102.tar.gz
-rw-rw-r-- katzj/katzj  446284 2003-05-23 19:04:46 rhpl-0.105.1/rhpl-0.102.1.tar.gz
-rw-rw-r-- katzj/katzj  446465 2003-05-30 14:10:18 rhpl-0.105.1/rhpl-0.103.tar.gz
Comment 2 Jeremy Katz 2003-07-03 01:07:14 EDT
Oops, must have used the wrong makefile target.  -3 building.

Note You need to log in before you can comment on or make changes to this bug.