Bug 985193 - creating md RAID from previously created disks layout not possible
creating md RAID from previously created disks layout not possible
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 01:02 EDT by Frantisek Hanzlik
Modified: 2013-07-18 11:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 11:47:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Hanzlik 2013-07-17 01:02:24 EDT
Description of problem:
Installing F19 on two same 500 GB disks, disks was divided with gdisk before installation, their partitions are:
1) 1MB ef02 BIOS boot
2) 350MB fd00 (contemplated as member of md RAID1 for ext4 /boot)
3) 4 GB 8200 (should be swap spaces, not in SW RAID)
4) 24 GB fd00 (contemplated as member of md RAID1 for ext4 root fs /)
5) 24 GB fd00 (contemplated as member of md RAID1 for other Linux distro)
6) ~200 GB fd00 (contemplated as member of md RAID1 for ext4 home fs /home)
7) ~200 GB fd00 (contemplated as member of md RAID1 for other ext4 fs)

anaconda Custom Partitioning shows all these partitions as 'Unknown' types; I can 'Reformat' partition 1) as BIOS Boot, partition 3) as swap - but it seems as there is no way how tell to anaconda for creating md SW RAIDs. In previous anaconda versions there was option 'reformat' these partitions as 'SW RAID' and then assemble RAIDs from them, but this possibility seems not be in F19 anaconda.

Version-Release number of selected component (if applicable):
anaconda-19.30.13-1
Comment 1 David Lehman 2013-07-17 11:12:41 EDT
You can either allow the installer to create your arrays from free space on disk or you can actually create the arrays before beginning the installation.
Comment 2 Frantisek Hanzlik 2013-07-17 13:08:30 EDT
(In reply to David Lehman from comment #1)
> You can either allow the installer to create your arrays from free space on
> disk or you can actually create the arrays before beginning the installation.

Hmm, IMO this isn't acceptable solution, as:

1) allowing the installer to create md arrays isn't always possible (e.g. I want GPT partition on i386 arch or want precise division (to LBAs, not {M,G,T}Bytes) and ordering individual partitions or creatin md on whole disks without partitionig them,...)

2) Manually create arrays before beginning the installation - reasonable idea, but when I did it, anaconda crashes for me - see bug https://bugzilla.redhat.com/show_bug.cgi?id=985207 which I thing maybe caused due to all arrays still was not resynced in installation time. And wait several (or several tens) of hours to md RAID syncing is perhaps to crazy. You can object to create only small system partitions which synces promptly and all bigger MDs create after installation, but... (it would be perhaps backspace).

PS: On other hand, in many areas (e.g. language/keyboard layout selection possibility, rescan disks possibility,..) I was fairly surprised with F19 anaconda (compared to F18). Thus, many thanks for these improvements, and I wish success to all its team.
Comment 3 David Lehman 2013-07-18 11:47:08 EDT
If there is a bug preventing you from creating your arrays outside of anaconda we will work on fixing that. There are no plans to support creation of md, lvm, or btrfs volumes using existing member partitions in anaconda.

Note You need to log in before you can comment on or make changes to this bug.