Bug 985309 - Missing tools and libraries needed for BRMS/BPMS clustering
Missing tools and libraries needed for BRMS/BPMS clustering
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Build and Assembly (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Maciej Swiderski
Radovan Synek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 05:37 EDT by Radovan Synek
Modified: 2014-08-06 16:11 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radovan Synek 2013-07-17 05:37:26 EDT
In order to get BRMS/BPMS cluster running, several third party tools & libraries are needed, namely:
apache helix (http://helix.incubator.apache.org/) BRMS/BPMS
apache zookeeper (http://zookeeper.apache.org/) BRMS/BPMS
quartz scheduler (http://quartz-scheduler.org/) BPMS only

See this blog post [1] for more details.

User has to download them and integrate with BRMS/BPMS on his own.
=> I would expect to have these tools as a part of BRMS/BPMS distribution with some integration already done and with basic examples of usage (if possible).

[1] http://mswiderski.blogspot.com.br/2013/06/clustering-in-jbpm-v6.html
Comment 1 Prakash Aradhya 2013-07-18 10:20:12 EDT
Yes, they are needed libraries.  How did we miss them ?
I suspected they are included in the community beta...
Comment 4 Ryan Zhang 2013-07-24 05:04:56 EDT
(In reply to Radovan Synek from comment #0)
> In order to get BRMS/BPMS cluster running, several third party tools &
> libraries are needed, namely:
> apache helix (http://helix.incubator.apache.org/) BRMS/BPMS
> apache zookeeper (http://zookeeper.apache.org/) BRMS/BPMS
> quartz scheduler (http://quartz-scheduler.org/) BPMS only
> 
> See this blog post [1] for more details.
> 
> User has to download them and integrate with BRMS/BPMS on his own.
> => I would expect to have these tools as a part of BRMS/BPMS distribution
> with some integration already done and with basic examples of usage (if
> possible).
> 
> [1] http://mswiderski.blogspot.com.br/2013/06/clustering-in-jbpm-v6.html
Radovan,
I checked the DR6, the 3 jars(helix, zookeeper, quartz) are included in WEB-INF/lib.
So I suppose you are saying that we would need to provide the scripts and configuration for the product, right?
Comment 5 Radovan Synek 2013-07-24 08:36:11 EDT
Hi Ryan,

> Radovan,
> I checked the DR6, the 3 jars(helix, zookeeper, quartz) are included in
> WEB-INF/lib.

Jars inside WEB-INF/lib are probably just API needed by jboss-brms/business-central. The cluster setup needs whole distribution of helix and zookeeper. Regarding quartz, there are missing DDL scripts, which are again part of complete quartz distribution.

> So I suppose you are saying that we would need to provide the scripts and
> configuration for the product, right?

What I would expect is providing some scripts to ease the cluster setup - I understand that it's not possible to provide complete setup, because we don't know how many nodes client wants, but what about creating some example script for basic helix and zookeeper setup (the same as in [1], two nodes only)?

Similarly for Quartz - to provide example configuration, maybe create the datasource.

This is just an idea, which can be discussed.
Comment 6 Alexandre Porcelli 2013-07-24 10:37:57 EDT
For ZooKeeper there isn't much we can do other than have a documented receipt for simple cases (probably we already have something like that, once Fuse uses ZK extensively).

Now about Apache Helix, for community (6.1) we'll start to implement a better automation of its configuration, with the ultimate goal to hide all config details from users. I can't promise much right now, but in a couple of week I can give a better feedback on this automation and you'll be able to check if would be convenient or not back-port it to 6.0. If not possible we can provide the sample script.
Comment 7 Maciej Swiderski 2013-07-24 10:57:49 EDT
As it comes to Quartz, we could bundle in quartz related DDL scripts. What would be good to agree between community and product is the way they should be shipped. Just to avoid different ways of delivering such assets to the users. 

In general, I see this as part of the installer that shall be used to set this up for users completely. I believe that it fits to what Alexandre described in comment #6.
Comment 8 Alexandre Porcelli 2013-07-24 11:07:25 EDT
Just to make it clear, regarding Apache Helix automation: it's not related to installation script, the solution proposed will be (well, at least we'll try to make it happen) completely code based and transparent - the system will automagically setup itself (cluster, resources, nodes and etc).
Comment 16 Pedro Zapata 2013-08-07 04:58:12 EDT
Feedback summary from Jeffrey Bride

- Reduce as much as possible the number of shipped jars
- Some jars might not be required: bitronix, restlet and seam-transactions
Comment 17 Maciej Swiderski 2013-09-05 10:55:24 EDT
with this commit https://github.com/droolsjbpm/jbpm/commit/51aa3c1b6c06fce05c1029d5b3e27f8abece431e there are now DDL scripts for both jbpm, task and quartz tables available for most common data bases. With that hibernate auto ddl might be set to validate only when DDL are executed on data base in advance. They are stored in jbpm-installer/db/ddl-scripts but for product it might be copied/moved to more proper location as installer is not used.
These DDL scripts were built with hibernate tools based on persistence.xml using proper dialect so they should be exactly the same as when created by hbm.ddl.auto.

That should be all from quartz point of view but leaving BZ open for further work on helix and zookeeper which I believe will be for 6.1.
Comment 18 Maciej Swiderski 2013-09-20 06:18:11 EDT
marking this bz as modified as from quartz point of view DDL scripts are provided and further improvements will be tracked as part of https://bugzilla.redhat.com/show_bug.cgi?id=1010228
Comment 20 Radovan Synek 2013-10-18 03:06:48 EDT
Verified on BPMS-6.0.0.ER4 - Helix, Zookeeper and Quartz DDL are contained in supplementary tools.

Note You need to log in before you can comment on or make changes to this bug.