Bug 985335 - firebird-devel is not usable
firebird-devel is not usable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firebird (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Philippe Makowski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 06:10 EDT by David Tardon
Modified: 2013-08-14 23:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: firebird-2.5.2.26539.0-7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 23:03:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tardon 2013-07-17 06:10:35 EDT
Description of problem:
firebird-devel installs neither fb_config nor .pc files, which makes it very hard to know what CFLAGS and libs one is expected to use. And it unconditionally breaks configure tests, which expect that one or the other is available.

Version-Release number of selected component (if applicable):
firebird-2.5.2.26539.0-5.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. yum install firebird-devel
2. try to build a project that requires firebird for build, e.g., current checkout of libreoffice master

Actual results:
configure failure

Expected results:
configure detects firebird

Additional info:
fb_config is present in firebird package, but it should be in firebird-devel. Alternatively, if it is not purely a build tool, firebird-devel should depend on the main package.
Comment 1 Philippe Makowski 2013-07-17 12:24:06 EDT
perhaps better to convince upstream to provide  .pc files
but in fact, what don you really need exactly ?
because other driver doesn't express this need
and if fact fb_config provide information that are easy to guess
other point there is two version of fb_config, one for Firebird Superserver, another one for Firebird Classic
they differ only one one point : fb_bindir

others are for 64 bits:

fb_libdir=/usr/lib64
fb_incdir=/usr/include/firebird
fb_udfdir=/usr/lib64/firebird/UDF
fb_sbindir=/usr/sbin
fb_confdir=/etc/firebird
fb_docdir=/usr/share/doc/firebird
fb_sampledir=/usr/share/doc/firebird/examples
fb_sampledbdir=/var/lib/firebird/data/
fb_helpdir=/var/lib/firebird/system/
fb_intldir=/usr/lib64/firebird/intl
fb_miscdir=/usr/lib64/firebird/misc
fb_securedbdir=/var/lib/firebird/system
fb_msgdir=/var/lib/firebird/system
fb_logdir=/var/log/firebird
fb_glockdir=/var/run/firebird
fb_pluginsdir=/usr/lib64/firebird/plugins-classic

fb_cflags="-I$fb_incdir"
fb_libs="-L$fb_libdir -lfbclient"
fb_embedlibs="-L$fb_libdir -lfbembed"

BuildVersion=2.5.2.26539
PackageVersion=0
CpuType=amd64

Version="$BuildVersion-$PackageVersion.$CpuType"

fb_version=$Version
Comment 2 David Tardon 2013-07-19 06:30:29 EDT
(In reply to Philippe Makowski from comment #1)
> perhaps better to convince upstream to provide  .pc files

Yes, that would be the best solution.

> but in fact, what don you really need exactly ?

I want to be able to install firebird-devel and have all I need to configure and build a package that uses firebird :-)

> because other driver doesn't express this need
> and if fact fb_config provide information that are easy to guess

But the whole point of similar config tools (and pkgconfig files) is to avoid guessing. Because 1/ it is unreliable and 2/ it duplicates work someone else has already done (and put the results into the config tool).

> other point there is two version of fb_config, one for Firebird Superserver,
> another one for Firebird Classic
> they differ only one one point : fb_bindir

Oh, well... I suppose I am going to have to live with explicit dependency on firebird then.
Comment 3 Fedora Update System 2013-07-23 18:09:38 EDT
firebird-2.5.2.26539.0-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/firebird-2.5.2.26539.0-6.fc19
Comment 4 Fedora Update System 2013-07-24 20:42:49 EDT
Package firebird-2.5.2.26539.0-6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firebird-2.5.2.26539.0-6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13555/firebird-2.5.2.26539.0-6.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-08-01 16:57:48 EDT
firebird-2.5.2.26539.0-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/firebird-2.5.2.26539.0-7.fc19
Comment 6 Fedora Update System 2013-08-14 23:03:11 EDT
firebird-2.5.2.26539.0-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.