Bug 985363 - A command to build a project via CLI is missing
A command to build a project via CLI is missing
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: 6.0.0
Assigned To: Mario Fusco
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 06:58 EDT by Ivo Bek
Modified: 2014-08-06 16:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-07-17 06:58:26 EDT
Description of problem:

When I look at all the commands, which CLI provides, there is nothing I could use to build a project, because I need to build it first. After that I can add the deployment config.

I found the all commands here https://github.com/droolsjbpm/kie-wb-distributions/tree/master/kie-config-cli/src/main/java/org/kie/config/cli/command/impl

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 manstis 2013-07-18 11:56:01 EDT
kie-config-cli is meant for handling configuration data needed by kie-wb; e.g. setting up Groups, adding Repositories, managing permissions on these artifacts.

AFAIK KIE modules (KJAR's, or projects) can be built with Maven from the CLI (but don't ask me what the maven plugin is).. assigning to Mario (sorry) for comment...
Comment 2 Mario Fusco 2013-08-19 04:17:19 EDT
Michael is right; it is possible to build KIE modules from the maven CLI. To do that it is enough to add the drools-maven-plugin to your pom as in this example:

https://github.com/droolsjbpm/drools/blob/master/drools-maven-plugin-example/pom.xml
Comment 4 Ivo Bek 2013-09-19 11:03:20 EDT
Verified that drools-maven-plugin enables to build a kjar project.

Note You need to log in before you can comment on or make changes to this bug.