This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 985416 - p11-kit: p11_kit_space_strlen returns wrong value for empty string
p11-kit: p11_kit_space_strlen returns wrong value for empty string
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: p11-kit (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stef Walter
Aleš Mareček
:
Depends On:
Blocks: 983512
  Show dependency treegraph
 
Reported: 2013-07-17 08:51 EDT by Florian Weimer
Modified: 2013-11-21 06:39 EST (History)
2 users (show)

See Also:
Fixed In Version: p11-kit-0.18.5-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 06:39:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix p11_kit_space_strlen() result when empty string (3.86 KB, patch)
2013-07-18 00:49 EDT, Stef Walter
no flags Details | Diff

  None (edit)
Description Florian Weimer 2013-07-17 08:51:35 EDT
p11-kit/util.c:p11_kit_space_strlen() returns 1 if the string is empty (i.e., it contains of padding spaces only).
Comment 2 Stef Walter 2013-07-18 00:49:21 EDT
Created attachment 775105 [details]
Fix p11_kit_space_strlen() result when empty string
Comment 3 Stef Walter 2013-07-18 09:55:57 EDT
Pushed to p11-kit git stable branch, released as part of p11-kit 0.18.5. Package built for RHEL 6.5.
Comment 10 errata-xmlrpc 2013-11-21 06:39:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1626.html

Note You need to log in before you can comment on or make changes to this bug.