Bug 985421 - p11-kit: type mismatch in varargs
p11-kit: type mismatch in varargs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: p11-kit (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stef Walter
Aleš Mareček
:
Depends On:
Blocks: 983512
  Show dependency treegraph
 
Reported: 2013-07-17 09:00 EDT by Florian Weimer
Modified: 2013-11-21 06:40 EST (History)
2 users (show)

See Also:
Fixed In Version: p11-kit-0.18.5-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 06:40:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Always pass size_t varargs to p11_hash_xxx() functions (1.67 KB, patch)
2013-07-17 14:43 EDT, Stef Walter
no flags Details | Diff
Always pass size_t varargs to p11_hash_xxx() functions (4.41 KB, patch)
2013-07-18 06:01 EDT, Stef Walter
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1626 normal SHIPPED_LIVE new packages: p11-kit 2013-11-20 16:53:58 EST

  None (edit)
Description Florian Weimer 2013-07-17 09:00:50 EDT
tools/extract-jks.c:prepare_jks_buffer() invokes p11_hash_sha1() with an int argument where a size_t is expected.  This is not portable.

common/x509.c:p11_x509_calc_keyid() has the same problem.
Comment 2 Stef Walter 2013-07-17 14:43:32 EDT
Created attachment 774913 [details]
Always pass size_t varargs to p11_hash_xxx() functions
Comment 3 Stef Walter 2013-07-18 06:01:45 EDT
Created attachment 775242 [details]
Always pass size_t varargs to p11_hash_xxx() functions
Comment 4 Stef Walter 2013-07-18 09:55:56 EDT
Pushed to p11-kit git stable branch, released as part of p11-kit 0.18.5. Package built for RHEL 6.5.
Comment 11 errata-xmlrpc 2013-11-21 06:40:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1626.html

Note You need to log in before you can comment on or make changes to this bug.