Bug 985497 - p11-kit: buffer_append_printf format string
p11-kit: buffer_append_printf format string
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: p11-kit (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.1
Assigned To: Stef Walter
Aleš Mareček
:
Depends On:
Blocks: 983512 1152234
  Show dependency treegraph
 
Reported: 2013-07-17 11:46 EDT by Florian Weimer
Modified: 2015-03-05 02:54 EST (History)
2 users (show)

See Also:
Fixed In Version: p11-kit-0.20.4-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1152234 (view as bug list)
Environment:
Last Closed: 2015-03-05 02:54:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attrs: Check printf formatting in buffer_append_printf() (814 bytes, patch)
2013-07-17 12:53 EDT, Stef Walter
no flags Details | Diff

  None (edit)
Description Florian Weimer 2013-07-17 11:46:39 EDT
common/attrs.c:buffer_append_printf() should have a prototype with a GNUC_PRINTF(2, 3) attribute.

(It might make sense to move this function to buffer/common.c because it is rather generic.)
Comment 2 Stef Walter 2013-07-17 12:53:09 EDT
Created attachment 774860 [details]
attrs: Check printf formatting in buffer_append_printf()
Comment 4 Stef Walter 2013-07-18 09:51:55 EDT
Pushed patch to git master, and released as part of p11-kit 0.19.2 development release.
Comment 10 errata-xmlrpc 2015-03-05 02:54:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0339.html

Note You need to log in before you can comment on or make changes to this bug.