Bug 985544 - SELinux is preventing /usr/bin/nspluginviewer from using the 'signal' accesses on a process.
SELinux is preventing /usr/bin/nspluginviewer from using the 'signal' accesse...
Status: CLOSED DUPLICATE of bug 807641
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:fd8249d4edec1088e8080696d1a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 13:39 EDT by Rex Dieter
Modified: 2013-07-17 13:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 13:44:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2013-07-17 13:39:54 EDT
Description of problem:
Using konqueror webbrowser with khtml engine on youtube.com using flash-plugin
SELinux is preventing /usr/bin/nspluginviewer from using the 'signal' accesses on a process.

*****  Plugin mozplugger (99.1 confidence) suggests  *************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests  ***************************

If you believe that nspluginviewer should be allowed signal access on processes labeled unconfined_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep nspluginviewer /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                 [ process ]
Source                        nspluginviewer
Source Path                   /usr/bin/nspluginviewer
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kde-baseapps-4.10.5-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-63.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-302.fc19.x86_64 #1 SMP Sat
                              Jul 6 13:41:07 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-17 12:00:54 CDT
Last Seen                     2013-07-17 12:00:54 CDT
Local ID                      37ed45b3-dcfb-47d6-aa63-14792d45fd9a

Raw Audit Messages
type=AVC msg=audit(1374080454.346:831): avc:  denied  { signal } for  pid=7599 comm="nspluginviewer" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process


type=SYSCALL msg=audit(1374080454.346:831): arch=x86_64 syscall=kill success=no exit=EACCES a0=1dbc a1=f a2=14f2b70 a3=7fff53b57620 items=0 ppid=7496 pid=7599 auid=1000 uid=1000 gid=0 euid=1000 suid=1000 fsuid=1000 egid=0 sgid=0 fsgid=0 ses=1 tty=(none) comm=nspluginviewer exe=/usr/bin/nspluginviewer subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: nspluginviewer,mozilla_plugin_t,unconfined_t,process,signal

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-302.fc19.x86_64
type:           libreport

Potential duplicate: bug 807641
Comment 1 Rex Dieter 2013-07-17 13:44:39 EDT
Seems to function ok despite the denial, commentary from bug #807641 still seems accurate.

*** This bug has been marked as a duplicate of bug 807641 ***

Note You need to log in before you can comment on or make changes to this bug.