Bug 985555 - [abrt] transmission-gtk-2.80-1.fc19: pthread_cond_timedwait@@GLIBC_2.3.2: Process /usr/bin/transmission-gtk was killed by signal 11 (SIGSEGV)
[abrt] transmission-gtk-2.80-1.fc19: pthread_cond_timedwait@@GLIBC_2.3.2: Pro...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
abrt_hash:ccebbcff10a0790683bd5f85779...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 14:39 EDT by Sergey Kurtsev
Modified: 2013-07-20 13:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-20 13:26:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (19.26 KB, text/plain)
2013-07-17 14:39 EDT, Sergey Kurtsev
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-17 14:39 EDT, Sergey Kurtsev
no flags Details
File: core_backtrace (708 bytes, text/plain)
2013-07-17 14:39 EDT, Sergey Kurtsev
no flags Details
File: dso_list (11.51 KB, text/plain)
2013-07-17 14:39 EDT, Sergey Kurtsev
no flags Details
File: environ (2.46 KB, text/plain)
2013-07-17 14:39 EDT, Sergey Kurtsev
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-17 14:39 EDT, Sergey Kurtsev
no flags Details
File: maps (37.83 KB, text/plain)
2013-07-17 14:39 EDT, Sergey Kurtsev
no flags Details
File: open_fds (6.56 KB, text/plain)
2013-07-17 14:40 EDT, Sergey Kurtsev
no flags Details
File: proc_pid_status (798 bytes, text/plain)
2013-07-17 14:40 EDT, Sergey Kurtsev
no flags Details
File: var_log_messages (310 bytes, text/plain)
2013-07-17 14:40 EDT, Sergey Kurtsev
no flags Details

  None (edit)
Description Sergey Kurtsev 2013-07-17 14:39:12 EDT
Version-Release number of selected component:
transmission-gtk-2.80-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        transmission-gtk magnet:?xt=urn:btih:d59dc193a7aff8fdd0e7496bc4549c658a105fad&dn=Radiohead+Complete+Studio+Discography+%5BFLAC%5D&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=udp%3A%2F%2Ftracker.istole.it%3A6969&tr=udp%3A%2F%2Ftracker.ccc.de%3A80&tr=udp%3A%2F%2Fopen.demonii.com%3A1337
crash_function: pthread_cond_timedwait@@GLIBC_2.3.2
executable:     /usr/bin/transmission-gtk
kernel:         3.9.9-301.fc19.i686.PAE
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 7 (7 frames)
 #1 pthread_cond_timedwait@@GLIBC_2.3.2 at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S:250
 #2 g_cond_wait_until at gthread-posix.c:859
 #3 g_async_queue_pop_intern_unlocked at gasyncqueue.c:424
 #4 g_async_queue_timeout_pop at gasyncqueue.c:545
 #5 g_thread_pool_wait_for_new_pool at gthreadpool.c:169
 #7 g_thread_proxy at gthread.c:798
 #8 ??
Comment 1 Sergey Kurtsev 2013-07-17 14:39:18 EDT
Created attachment 774901 [details]
File: backtrace
Comment 2 Sergey Kurtsev 2013-07-17 14:39:22 EDT
Created attachment 774902 [details]
File: cgroup
Comment 3 Sergey Kurtsev 2013-07-17 14:39:26 EDT
Created attachment 774903 [details]
File: core_backtrace
Comment 4 Sergey Kurtsev 2013-07-17 14:39:33 EDT
Created attachment 774904 [details]
File: dso_list
Comment 5 Sergey Kurtsev 2013-07-17 14:39:40 EDT
Created attachment 774905 [details]
File: environ
Comment 6 Sergey Kurtsev 2013-07-17 14:39:48 EDT
Created attachment 774906 [details]
File: limits
Comment 7 Sergey Kurtsev 2013-07-17 14:39:52 EDT
Created attachment 774907 [details]
File: maps
Comment 8 Sergey Kurtsev 2013-07-17 14:40:00 EDT
Created attachment 774908 [details]
File: open_fds
Comment 9 Sergey Kurtsev 2013-07-17 14:40:08 EDT
Created attachment 774909 [details]
File: proc_pid_status
Comment 10 Sergey Kurtsev 2013-07-17 14:40:12 EDT
Created attachment 774910 [details]
File: var_log_messages
Comment 11 Charles Kerr 2013-07-20 13:26:09 EDT
The crash took place in g_type_check_instance_cast() so this *may* be the same as bug #967388. Unfortunately the backtrace is corrupt and doesn't show where the instance cast call came from, so there's no way to be sure.

I'm going to mark this as a CANTFIX due to insufficient information. Sergey, if you can reproduce the crash, please file a new ticket so that a new backtrace will get generated. Thanks.

Note You need to log in before you can comment on or make changes to this bug.