Bug 985603 - cups-browsed.service not enabled by default
cups-browsed.service not enabled by default
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 16:56 EDT by Andrew Blum
Modified: 2013-07-18 03:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 03:18:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Blum 2013-07-17 16:56:07 EDT
Description of problem:
The BrowsePoll directive has been moved from to the new cups-browsed daemon (https://bugzilla.redhat.com/show_bug.cgi?id=881101).

The cups-browsed daemon is not enabled by default however.

Version-Release number of selected component (if applicable):
cups-1.6.2-12.fc19.x86_64
cups-filters-1.0.34-7.fc19.x86_64


Steps to Reproduce:
1. Look at systemctl output from a default F19 install

Actual results:
 systemctl | grep cups
cups.path                   loaded active waiting   CUPS Printer Service Spool
cups.service                loaded active running   CUPS Printing Service
cups.socket                 loaded active running   CUPS Printing Service Sockets


Expected results:
# systemctl | grep cups
cups.path                   loaded active waiting   CUPS Printer Service Spool
cups-browsed.service        loaded active running   Make remote CUPS printers available locally
cups.service                loaded active running   CUPS Printing Service
cups.socket                 loaded active running   CUPS Printing Service Sockets


Additional info:
Needed to add the BrowsePoll to /etc/cups/cups-browsed.conf (though the configuration file did exist)

# egrep ^BrowsePoll /etc/cups/cups-browsed.conf
BrowsePoll my.example.print.server:631

Then enable and start the cups-browsed unit:

# systemctl enable cups-browsed.service
# systemctl start cups-browsed.service
Comment 1 Tim Waugh 2013-07-18 03:18:52 EDT
I don't think it should be enabled by default.

The only built-in mechanism for CUPS print queue discovery is DNS-SD, using Avahi. Discovery is done in the client application (in libcups). DNS-SD support for CUPS is in all supported releases of Fedora.

The Browsing/BrowsePoll support in cups-browsed is for people who cannot use DNS-SD for discovery for any reason. It is a "last resort", provided for compatibility reasons.

Enabling the cups-browsed service automatically would cause duplication of queues in systems where the DNS-SD support already works automatically (i.e. remote CUPS server supports DNS-SD, Avahi running on local system and not firewalled off).
Comment 2 Jiri Popelka 2013-07-18 03:35:42 EDT
Ok, I see Tim just commented, but here are also my 2c.

(In reply to Andrew Blum from comment #0)
> The BrowsePoll directive has been moved from to the new cups-browsed daemon

Yes, CUPS no longer supports cups browsing protocol because preferred mechanism has been DNS-SD. cups-browsed has been created as a backward compatibility tool.

> The cups-browsed daemon is not enabled by default however.

Correct and I don't see a reason why it should be.
It has a specific use and for example most of the users in home environment will never need it running.

Note You need to log in before you can comment on or make changes to this bug.