Bug 985607 - the configuration rpm should also reset the server.prefix to /subscription
the configuration rpm should also reset the server.prefix to /subscription
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 17:08 EDT by John Sefler
Modified: 2014-03-18 13:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-07-17 17:08:46 EDT
Description of problem:
As part of the setup process to configure a subscription-manager client to connect to a katello server, there is a convenience rpm built on the server that when installed will change the /etc/rhsm/rhsm.conf values appropriately.

Please include in that rpm an instruction to set the server.prefix=/subscription


For example:

[root@jsefler-5 ~]# rpm -Uvh http://intel-s3ea2-03.rhts.eng.bos.redhat.com/pub/candlepin-cert-consumer-intel-s3ea2-03.rhts.eng.bos.redhat.com-1.0-1.noarch.rpm
Retrieving http://intel-s3ea2-03.rhts.eng.bos.redhat.com/pub/candlepin-cert-consumer-intel-s3ea2-03.rhts.eng.bos.redhat.com-1.0-1.noarch.rpm
Preparing...                ########################################### [100%]
   1:candlepin-cert-consumer########################################### [100%]
[root@jsefler-5 ~]# cat /etc/rhsm/rhsm.conf
# Red Hat Subscription Manager Configuration File:

# Unified Entitlement Platform Configuration
[server]
# Server hostname:
hostname=intel-s3ea2-03.rhts.eng.bos.redhat.com

# Server prefix:
prefix=/candlepin    <=========== THAT'S MY FORMER DIRTY VALUE - FIX IT FOR ME

# Server port:
port=443

# Set to 1 to disable certificate validation:
insecure=0

# Set the depth of certs which should be checked
# when validating a certificate
ssl_verify_depth = 3

# Server CA certificate location:
ca_cert_dir = /etc/rhsm/ca/

# an http proxy server to use
proxy_hostname =

# port for http proxy server
proxy_port =

# user name for authenticating to an http proxy, if needed
proxy_user =

# password for basic http proxy auth, if needed
proxy_password =

[rhsm]
# Content base URL:
baseurl=https://intel-s3ea2-03.rhts.eng.bos.redhat.com/pulp/repos

# Default CA cert to use when generating yum repo configs:
repo_ca_cert=%(ca_cert_dir)scandlepin-local.pem

# Where the certificates should be stored
productCertDir=/etc/pki/product
entitlementCertDir=/etc/pki/entitlement
consumerCertDir=/etc/pki/consumer

# Manage generation of yum repositories for subscribed content:
manage_repos = 1

# If set to zero, the client will not report the package profile to
# the subscription management service.
report_package_profile = 1

# The directory to search for subscription manager plugins
pluginDir = /usr/share/rhsm-plugins

# The directory to search for plugin configuration files
pluginConfDir = /etc/rhsm/pluginconf.d

[rhsmcertd]
# Interval to run cert check (in minutes):
certCheckInterval = 2
# Interval to run auto-attach (in minutes):
autoAttachInterval = 1440
Comment 1 John Sefler 2013-07-25 16:16:44 EDT
The rpm should also reset the server.insecure=0
Comment 2 RHEL Product and Program Management 2013-09-17 00:22:32 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Mike McCune 2014-03-18 13:38:41 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.