Bug 985624 - Failed to execute parallel processes: no ssh and no restart
Failed to execute parallel processes: no ssh and no restart
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 19:37 EDT by rasmus
Modified: 2015-05-14 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-20 08:40:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rasmus 2013-07-17 19:37:34 EDT
Description of problem:

My app is here: 
   http://ttrss-rasmus.rhcloud.com/
   Uuid: 51a00b6d5973ca29ff000731

It is tiny tiny rss used only by me for evaluation. 

It stopped working some days ago.  I can force-stop it (rhc app force-stop ttrss), but that's about it.  I cannot restart the app (trace below) and I cannot ssh into it, even after I've force stopped it.  I can log into another Openshift project from this connection (and other ssh hosts).

Please let me know if I did some silly mistake.

Additional info:

I was asked to make a bug report in this thread

https://www.openshift.com/forums/openshift/error-failed-to-execute-parallel-processes#comment-32434


Actual results:

sh>  rhc app force-stop ttrss -d
     DEBUG  : Using config file /home/rasmus/.openshift/express.conf
     DEBUG  : Authenticating with RHC::Auth::Token
     DEBUG  : Connecting to https://openshift.redhat.com/broker/rest/api
     DEBUG  : Getting all domains
     DEBUG  : Client supports API versions 1.1, 1.2, 1.3, 1.4
     DEBUG  : Using token authentication
     DEBUG  : Request GET https://openshift.redhat.com/broker/rest/api
     DEBUG  :    code 200  645 ms
     DEBUG  : Server supports API versions 1.0, 1.1, 1.2, 1.3, 1.4, 1.5
     DEBUG  : Client API version 1.4 is not current. Refetching API
     DEBUG  : Using token authentication
     DEBUG  : Request GET https://openshift.redhat.com/broker/rest/api
     DEBUG  :    code 200  631 ms
     DEBUG  : Using token authentication
     DEBUG  : Request GET https://openshift.redhat.com/broker/rest/domains
     DEBUG  :    code 200  660 ms
     DEBUG  : Getting all domains
     DEBUG  : Using token authentication
     DEBUG  : Request GET https://openshift.redhat.com/broker/rest/domains/rasmus/applications/ttrss
     DEBUG  :    code 200  225 ms
     DEBUG  : Stopping application ttrss force-true
     DEBUG  : Using token authentication
     DEBUG  : Request POST https://openshift.redhat.com/broker/rest/domains/rasmus/applications/ttrss/events
     DEBUG  :    code 200 17781 ms
     RESULT : ttrss force stopped

sh> rhc app reload ttrss -d
    DEBUG   : Using config file /home/rasmus/.openshift/express.conf
    DEBUG   : Authenticating with RHC::Auth::Token
    DEBUG   : Connecting to https://openshift.redhat.com/broker/rest/api
    DEBUG   : Getting all domains
    DEBUG   : Client supports API versions 1.1, 1.2, 1.3, 1.4
    DEBUG   : Using token authentication
    DEBUG   : Request GET https://openshift.redhat.com/broker/rest/api
    DEBUG   :    code 200 1057 ms
    DEBUG   : Server supports API versions 1.0, 1.1, 1.2, 1.3, 1.4, 1.5
    DEBUG   : Client API version 1.4 is not current. Refetching API
    DEBUG   : Using token authentication
    DEBUG   : Request GET https://openshift.redhat.com/broker/rest/api
    DEBUG   :    code 200 1060 ms
    DEBUG   : Using token authentication
    DEBUG   : Request GET https://openshift.redhat.com/broker/rest/domains
    DEBUG   :    code 200 1042 ms
    DEBUG   : Getting all domains
    DEBUG   : Using token authentication
    DEBUG   : Request GET https://openshift.redhat.com/broker/rest/domains/rasmus/applications/ttrss
    DEBUG   :    code 200  399 ms
    DEBUG   : Reload application ttrss
    DEBUG   : Using token authentication
    DEBUG   : Request POST https://openshift.redhat.com/broker/rest/domains/rasmus/applications/ttrss/events
    DEBUG   :  code 503 50371 ms
    RESULT  : Application is currently busy performing another operation. Please try
               again in a minute.

## force restart and try again result in the same

sh>  rhc app start ttrss -d
     DEBUG  : Using config file /home/rasmus/.openshift/express.conf
     DEBUG  : Authenticating with RHC::Auth::Token
     DEBUG  : Connecting to https://openshift.redhat.com/broker/rest/api
     DEBUG  : Getting all domains
     DEBUG  : Client supports API versions 1.1, 1.2, 1.3, 1.4
     DEBUG  : Using token authentication
     DEBUG  : Request GET https://openshift.redhat.com/broker/rest/api
     DEBUG  :    code 200  745 ms
     DEBUG  : Server supports API versions 1.0, 1.1, 1.2, 1.3, 1.4, 1.5
     DEBUG  : Client API version 1.4 is not current. Refetching API
     DEBUG  : Using token authentication
     DEBUG  : Request GET https://openshift.redhat.com/broker/rest/api
     DEBUG  :    code 200 1034 ms
     DEBUG  : Using token authentication
     DEBUG  : Request GET https://openshift.redhat.com/broker/rest/domains
     DEBUG  :    code 200 1022 ms
     DEBUG  : Getting all domains
     DEBUG  : Using token authentication
     DEBUG  : Request GET https://openshift.redhat.com/broker/rest/domains/rasmus/applications/ttrss
     DEBUG  :    code 200  293 ms
     DEBUG  : Starting application ttrss
     DEBUG  : Using token authentication
     DEBUG  : Request POST https://openshift.redhat.com/broker/rest/domains/rasmus/applications/ttrss/events
     DEBUG  :    code 500 250347 ms
     Unable to complete the requested operation due to: Failed to correctly
     execute all parallel operations - --DEBUG--

     --RESULT--

     --MESSAGE--

     --ERROR--

     --APP INFO--

     --CART COMMANDS--

     --CART PROPERTIES--
     {}
     --DATA--

     --EXIT CODE--

     --USER ACTIONABLE--
     false
     .
     Reference ID: cce40a4e77f4ae3ce183856b9235d3cb

## Trying to ssh into it just freezes.  Same with git pull/fetch.

Expected results:

I should be able to at least ssh into the app to check what's wrong.
Comment 1 rasmus 2013-07-20 08:40:26 EDT
It is now working again, although I did not do anything. . .  Weird and wonderful, I guess.

Note You need to log in before you can comment on or make changes to this bug.