Bug 98564 - installer fails to load pcmcia ide_cs module, it's mis-named ide-cs?
installer fails to load pcmcia ide_cs module, it's mis-named ide-cs?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-03 15:22 EDT by man
Modified: 2007-03-27 00:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 14:23:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description man 2003-07-03 15:22:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
machine is toshiba portege 7020ct mini-laptop. has external floppy (which seems
to connect to traditional fdc) and external cdrom (which connects via pcmcia
card) which is an archos 'minicd'.

machine will not boot from pcmcia cdrom, but that is bios issue, so i did floppy
boot instead. first disk loads properly, when prompted for driver disk, i use
the pcmciadd.img disk, but after a couple seconds, the installer asks for
another disk, says it cant find the drive.

so, i switch over to console f3 and i see:

modules to insert: pcmcia_core i82365 ds

then it finds and installs each of these modules from the driver disk.

then (still on f3):

probing buses
finished bus probing
modules to insert ide_cs usb-uhci
module(s) ide_cs usb-uhci not found

so i go into the bios and i force the machine to use pccard mode (16bit) and get
the same result, except it uses yenta instead of i82365.

so, i tear into the cpio in the driver disk:

 cat modules.cgz | gunzip -c - | cpio -t

and i notice:

2.4.20-8BOOT/ide-cs.o

note the - rather than _ is that the problem?

Version-Release number of selected component (if applicable):
stock rh9 bootdisk

How reproducible:
Always

Steps to Reproduce:
1. get laptop with only pcmcia cd drive
2. try to install rh9 from cd using floppy boot
3. load pcmciadd disk.
    

Actual Results:  cant find install media, cause cant find drive.

Expected Results:  find drive, find media, install

Additional info:

drive works, connected it to an ibmthinkpad running unpatched rh9, found it and
mounted it no problem (even used it to install errata rpms on the thinkpad)
Comment 1 man 2003-07-07 11:54:40 EDT
update:

i have modified the redhat pcmciadd.img, changing ide-cs to ide_cs in modinfo
and modules.dep, and renaming the ide-cs.o module to ide_cs.o.

i have used this updated disk to attempt to install the system, and the module
does load, but still wont find the drive.

on console f3:

module ide_cs found ...
loaded ide_cs from ...
module(s) usb-uhci not found
inserted /tmp/ide_cs.o
load module set done
going to activate device using ide_cs
activated, but unable to get device info

at which time, the drive spins up, and flashes a bit, and the eject button
works, but the installer still complains about no media.

i have tried this with both yenta and i82365, no difference.


Comment 2 man 2003-07-08 09:23:37 EDT
update:

have used rh8 boot disks to attempt to install, it actually 'sees' the cd drive,
and 'announces' (to anthropomorphize rhl yet again) that the second stage of the
installer does not match the first (which is true since i have the rh9 cd in the
drive).

so, this would seem to be rh9 specific. i notice that the ide modules from the
kernel vs pcmcia-cs packages are named differently (ide_cs and ide-cs). which
one does the rh9 installer kernel use?

Comment 3 Jeremy Katz 2003-07-08 14:50:40 EDT
ide-cs is the correct module name.  I don't actually see where ide_cs could be
coming from.  Will look some more.
Comment 4 Karsten Hopp 2003-07-16 08:38:26 EDT
it's coming from kudzu, fixed in CVS. 
Comment 5 Jeremy Katz 2006-04-24 14:23:31 EDT
Mass-closing lots of old bugs which are in MODIFIED (and thus presumed to be
fixed).  If any of these are still a problem, please reopen or file a new bug
against the release which they're occurring in so they can be properly tracked.

Note You need to log in before you can comment on or make changes to this bug.