Bug 985739 - Snapshot is marked with memory volumes that don't exists
Snapshot is marked with memory volumes that don't exists
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity medium
: ---
: 3.3.0
Assigned To: Arik
Tareq Alayan
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 02:37 EDT by Arik
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version: is7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:14:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (92.31 KB, application/x-gzip)
2013-07-18 02:37 EDT, Arik
no flags Details
screenshot1 (47.65 KB, image/png)
2013-07-29 11:01 EDT, Tareq Alayan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17247 None None None Never
oVirt gerrit 17248 None None None Never

  None (edit)
Description Arik 2013-07-18 02:37:13 EDT
Created attachment 775130 [details]
engine log

Description of problem:
Snapshot is defined with memory state, even though they don't really exist. The problem is that the CreateAllSnapshotsFromVm doesn't remove the memory volumes from the snapshot in case the VM is going down after the command starts (so no live snapshot is made).
Note that in this case, where snapshot is defined with memory state that don't exist, the VM cannot be removed.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Run VM
2. Choose to create snapshot with memory
3. Shutdown the VM right after

Actual results:
The snapshot is defined with memory state although they don't exist

Expected results:
The snapshot definition doesn't contain memory state

Additional info:
Comment 1 Tareq Alayan 2013-07-29 10:58:39 EDT
1- I ran a VM
2. create a snabpshot with save memory checked
3. shut down afterwards


- events tab notification showed that the sanpshot has been completed.
- i cannot see the snapshot name under the snapshot tab


attached screenshot, logs
Comment 2 Tareq Alayan 2013-07-29 11:01:14 EDT
Created attachment 779974 [details]
screenshot1
Comment 3 Tareq Alayan 2013-07-29 11:08:03 EDT
switch back to ON_QA 

i had to refresh the UI and it showed up after.
Comment 4 Itamar Heim 2014-01-21 17:14:01 EST
Closing - RHEV 3.3 Released
Comment 5 Itamar Heim 2014-01-21 17:21:49 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.