Bug 985752 - Dist-geo-rep : geo-rep logs says falling back to xtime when is it actually falling back to xsync
Dist-geo-rep : geo-rep logs says falling back to xtime when is it actually fa...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Avra Sengupta
Vijaykumar Koppad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 03:20 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-07-18 03:20:43 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Vijaykumar Koppad 2013-07-18 03:48:31 EDT
Description of problem: If the changelog translator is disabled, the logs says falling back to xtime , when actually it is falling back to xsync. 

[2013-07-18 12:36:49.519987] I [master(/bricks/brick3):784:fallback_xsync] _GMaster: falling back to xtime mode
[2013-07-18 12:36:49.532391] I [syncdutils(/bricks/brick3):158:finalize] <top>: exiting.


Version-Release number of selected component (if applicable):3.4.0.12rhs.beta4-1.el6rhs.x86_64


How reproducible:Happens everytime


Steps to Reproduce:
1.Create and start a geo-rep relationship between master and slave.
2.Disable the changelog using set command 
3.Check the geo-rep logs 

Actual results: geo-rep logs  says falling back to xtime mode when it is actually falling back to xsync.


Expected results: It should say falling back to xsync. 


Additional info:
Comment 3 Avra Sengupta 2013-07-22 04:48:40 EDT
Had fixed it in upstream patch. Porting the change in big bend beta as well
Comment 4 Vijaykumar Koppad 2013-07-24 09:21:10 EDT
Verified on the build 3.4.0.12rhs.beta6-1.el6rhs.x86_64
Comment 5 Scott Haines 2013-09-23 18:38:45 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:41:29 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.