Bug 985754 - [abrt] evolution-data-server-3.8.3-1.fc19: Process /usr/libexec/evolution-calendar-factory was killed by signal 6 (SIGABRT)
[abrt] evolution-data-server-3.8.3-1.fc19: Process /usr/libexec/evolution-cal...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:0dfe34660acc05101798615269a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 03:35 EDT by Martin Pavlik
Modified: 2015-04-06 23:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 13:03:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (33.55 KB, text/plain)
2013-07-18 03:35 EDT, Martin Pavlik
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-18 03:35 EDT, Martin Pavlik
no flags Details
File: core_backtrace (537 bytes, text/plain)
2013-07-18 03:35 EDT, Martin Pavlik
no flags Details
File: dso_list (3.12 KB, text/plain)
2013-07-18 03:35 EDT, Martin Pavlik
no flags Details
File: environ (973 bytes, text/plain)
2013-07-18 03:36 EDT, Martin Pavlik
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-18 03:36 EDT, Martin Pavlik
no flags Details
File: maps (90.66 KB, text/plain)
2013-07-18 03:36 EDT, Martin Pavlik
no flags Details
File: open_fds (809 bytes, text/plain)
2013-07-18 03:36 EDT, Martin Pavlik
no flags Details
File: proc_pid_status (937 bytes, text/plain)
2013-07-18 03:36 EDT, Martin Pavlik
no flags Details
File: var_log_messages (451 bytes, text/plain)
2013-07-18 03:36 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2013-07-18 03:35:39 EDT
Description of problem:
I've tried to check my calendar after logging in to my GOA on google.

Version-Release number of selected component:
evolution-data-server-3.8.3-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 3
cmdline:        /usr/libexec/evolution-calendar-factory
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (5 frames)
 #0 ?? at /lib64/libc.so.6
 #1 __sigaddset at ../sysdeps/unix/sysv/linux/bits/sigset.h:118
 #2 sigset at ../sysdeps/posix/sigset.c:45
 #3 _fitoa_word at _itoa.c:470
 #5 qsort_r at msort.c:265
Comment 1 Martin Pavlik 2013-07-18 03:35:43 EDT
Created attachment 775157 [details]
File: backtrace
Comment 2 Martin Pavlik 2013-07-18 03:35:47 EDT
Created attachment 775158 [details]
File: cgroup
Comment 3 Martin Pavlik 2013-07-18 03:35:51 EDT
Created attachment 775159 [details]
File: core_backtrace
Comment 4 Martin Pavlik 2013-07-18 03:35:56 EDT
Created attachment 775160 [details]
File: dso_list
Comment 5 Martin Pavlik 2013-07-18 03:36:00 EDT
Created attachment 775161 [details]
File: environ
Comment 6 Martin Pavlik 2013-07-18 03:36:04 EDT
Created attachment 775162 [details]
File: limits
Comment 7 Martin Pavlik 2013-07-18 03:36:08 EDT
Created attachment 775163 [details]
File: maps
Comment 8 Martin Pavlik 2013-07-18 03:36:12 EDT
Created attachment 775164 [details]
File: open_fds
Comment 9 Martin Pavlik 2013-07-18 03:36:15 EDT
Created attachment 775165 [details]
File: proc_pid_status
Comment 10 Martin Pavlik 2013-07-18 03:36:22 EDT
Created attachment 775166 [details]
File: var_log_messages
Comment 11 Milan Crha 2013-07-18 07:54:09 EDT
Thanks for a bug report. I guess this happened due to update of
the evolution-data-server package, at least the var_log_messages mentions:
> Jul 17 21:25:17 mpavlik-laptop abrt[29635]: File '/usr/libexec/evolution-
> calendar-factory.#prelink#.WcdWFB' seems to be deleted
> Jul 17 21:25:18 mpavlik-laptop abrt[29635]: File '/usr/libexec/evolution-
> calendar-factory.#prelink#.WcdWFB' seems to be a prelink temporary file
> Jul 17 21:25:18 mpavlik-laptop abrt[29635]: Saved core dump of pid 1573
> (/usr/libexec/evolution-calendar-factory) to /var/tmp/abrt/ccpp-
> 2013-07-17-21:25:17-1573 (89862144 bytes)

and the backtrace itself claims multiple times:
> Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Most interestingly gdb claims on the first line of the backtrace:
> warning: core file may not match specified executable file.

which all seems like being caused by the update of certain packages. Could you try to close/kill all evolution processes (ps ax | grep evolution), or just reboot, whether it'll help, please?
Comment 12 Martin Pavlik 2013-07-18 08:38:24 EDT
after yum update and reboot it works fine

(In reply to Milan Crha from comment #11)
> Thanks for a bug report. I guess this happened due to update of
> the evolution-data-server package, at least the var_log_messages mentions:
> > Jul 17 21:25:17 mpavlik-laptop abrt[29635]: File '/usr/libexec/evolution-
> > calendar-factory.#prelink#.WcdWFB' seems to be deleted
> > Jul 17 21:25:18 mpavlik-laptop abrt[29635]: File '/usr/libexec/evolution-
> > calendar-factory.#prelink#.WcdWFB' seems to be a prelink temporary file
> > Jul 17 21:25:18 mpavlik-laptop abrt[29635]: Saved core dump of pid 1573
> > (/usr/libexec/evolution-calendar-factory) to /var/tmp/abrt/ccpp-
> > 2013-07-17-21:25:17-1573 (89862144 bytes)
> 
> and the backtrace itself claims multiple times:
> > Backtrace stopped: previous frame inner to this frame (corrupt stack?)
> 
> Most interestingly gdb claims on the first line of the backtrace:
> > warning: core file may not match specified executable file.
> 
> which all seems like being caused by the update of certain packages. Could
> you try to close/kill all evolution processes (ps ax | grep evolution), or
> just reboot, whether it'll help, please?
Comment 13 Milan Crha 2013-07-18 13:03:11 EDT
Good, thanks. I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.