Bug 985756 - Sometimes meet set -x syntax error reported when creating a ruby app in STG
Sometimes meet set -x syntax error reported when creating a ruby app in STG
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Hiro Asari
libra bugs
:
Depends On:
Blocks: 984818
  Show dependency treegraph
 
Reported: 2013-07-18 03:40 EDT by Zhe Wang
Modified: 2015-05-14 19:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 12:17:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhe Wang 2013-07-18 03:40:40 EDT
Description of problem:
When creating a ruby (1.8 or 1.9) app in STG(devenv-stage_414), the following error is reported:

Creating application 'rb9' ... 
+ set -xsource /usr/lib/openshift/cartridge_sdk/bash/sdk
/var/lib/openshift/51e79a2cdbd93c6a61000003/ruby/bin/install: line 3: set: -s: invalid option
set: usage: set [--abefhkmnptuvxBCHP] [-o option-name] [arg ...]

On the other hand, there is no such problem in devenv-stage_414 instance. This bug could be caused by the manual debugging in some nodes of STG for Bug 984818, since I did not notice any relevant codes in the error in stage branch. Moreover, I was able to create a ruby-1.8 app in node2 of STG (ex-std-node2.stg.rhcloud.com), and the detail of the app is:

  URL:        http://rb82-zwstg.stg.rhcloud.com/
  SSH to:     51e7993a2587c8278e00043c@rb82-zwstg.stg.rhcloud.com
  Git remote: ssh://51e7993a2587c8278e00043c@rb82-zwstg.stg.rhcloud.com/~/git/rb82.git/
  Cloned to:  /home/zhe/RedHat/runs/run101/njs1/rb82


Version-Release number of selected component (if applicable):
STG(devenv-stage_414)

How reproducible:
Sometimes

Steps to Reproduce:
1. create a ruby app, for example, ruby-1.9

Actual results:
The creation always reports h the errors blow:

Creating application 'rb9' ... 
+ set -xsource /usr/lib/openshift/cartridge_sdk/bash/sdk
/var/lib/openshift/51e79a2cdbd93c6a61000003/ruby/bin/install: line 3: set: -s: invalid option
set: usage: set [--abefhkmnptuvxBCHP] [-o option-name] [arg ...]

Expected results:
Creating a ruby pp should be successful.

Additional info:
Comment 1 Xiaoli Tian 2013-07-18 03:46:53 EDT
That's because on std_node3, have the following lines in /var/lib/openshift/.cartridge_repository/redhat-ruby/0.0.4/bin/install
#!/bin/bash -e
set -x
set -xsource $OPENSHIFT_CARTRIDGE_SDK_BASH
source "${OPENSHIFT_RUBY_DIR}/lib/util"

case "$1" in
  -v|--version)
    version="$2"
esac

( just checked this node, not sure if other nodes have this problem as well)
Maybe inserted by the manual debugging accidentally, the source code does not have this set -x in script.
Comment 3 Xiaoli Tian 2013-07-18 03:53:42 EDT
std-node1 has the same issue, maybe all the  nodes  except for node2 are affected.
Comment 4 Adam Miller 2013-07-18 12:17:54 EDT
This was a debugging step we were using to track down another issue that should have been removed but it was not. My apologies for this, it was an oversight of mine.

Note You need to log in before you can comment on or make changes to this bug.