Bug 985759 - no output from dmesg
no output from dmesg
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
19
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 03:58 EDT by Dan Horák
Modified: 2013-07-29 05:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 05:01:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2013-07-18 03:58:09 EDT
Description of problem:
The dmesg command produces no output on F-19 ARM

Version-Release number of selected component (if applicable):
kernel-3.9.9-302.fc19.armv7hl
util-linux-2.23.1-3.fc19.armv7hl

How reproducible:
100%

Steps to Reproduce:
1. run 'dmesg'

Actual results:
[root@calxeda-arm-soc-04 ~]# dmesg
[root@calxeda-arm-soc-04 ~]# 


Expected results (now produced by journalctl):
Jul 18 03:15:52 localhost systemd-journal[59]: Allowing runtime journal files to grow to 201.9M.
Jul 18 03:15:52 localhost kernel: Booting Linux on physical CPU 0x900
Jul 18 03:15:52 localhost kernel: Initializing cgroup subsys cpuset
Jul 18 03:15:52 localhost kernel: Initializing cgroup subsys cpu
Jul 18 03:15:52 localhost kernel: Linux version 3.9.9-302.fc19.armv7hl (mockbuild@arm04-builder00.arm.fedoraproject.org) (gcc version 4.8.1 20130603 (Red Hat 4.8.1-1)
Jul 18 03:15:52 localhost kernel: CPU: ARMv7 Processor [413fc090] revision 0 (ARMv7), cr=10c5387d
Jul 18 03:15:52 localhost kernel: CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
Jul 18 03:15:52 localhost kernel: Machine: Highbank, model: Calxeda Highbank
Jul 18 03:15:52 localhost kernel: Memory policy: ECC disabled, Data cache writealloc
Jul 18 03:15:52 localhost kernel: On node 0 totalpages: 1046784
Jul 18 03:15:52 localhost kernel: free_area_init_node: node 0, pgdat c08af680, node_mem_map c1a64000
Jul 18 03:15:52 localhost kernel:   Normal zone: 1520 pages used for memmap
Jul 18 03:15:52 localhost kernel:   Normal zone: 0 pages reserved
Jul 18 03:15:52 localhost kernel:   Normal zone: 194560 pages, LIFO batch:31
Jul 18 03:15:52 localhost kernel:   HighMem zone: 6658 pages used for memmap
...

Additional info:
[root@calxeda-arm-soc-04 ~]# strace dmesg
execve("/usr/bin/dmesg", ["dmesg"], [/* 40 vars */]) = 0
brk(0)                                  = 0x1887000
uname({sys="Linux", node="calxeda-arm-soc-04.lab.eng.brq.redhat.com", ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb6f0c000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY|O_CLOEXEC) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=47056, ...}) = 0
mmap2(NULL, 47056, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb6edb000
close(3)                                = 0
open("/lib/libgcc_s.so.1", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0(\0\1\0\0\0x\321\0\0004\0\0\0"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=121388, ...}) = 0
mmap2(NULL, 152676, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb6eb5000
mprotect(0xb6ed3000, 28672, PROT_NONE)  = 0
mmap2(0xb6eda000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1d000) = 0xb6eda000
close(3)                                = 0
open("/lib/libc.so.6", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0(\0\1\0\0\0\10\204\1\0004\0\0\0"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1621516, ...}) = 0
mmap2(NULL, 1357192, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb6d69000
mprotect(0xb6ea7000, 32768, PROT_NONE)  = 0
mmap2(0xb6eaf000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x13e000) = 0xb6eaf000
mmap2(0xb6eb2000, 9608, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xb6eb2000
close(3)                                = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb6f0b000
set_tls(0xb6f0b6d0, 0xb6f0bda8, 0xb6f0e000, 0xb6f0b6d0, 0xb6f0e000) = 0
mprotect(0xb6eaf000, 8192, PROT_READ)   = 0
mprotect(0x17000, 4096, PROT_READ)      = 0
mprotect(0xb6f0d000, 4096, PROT_READ)   = 0
munmap(0xb6edb000, 47056)               = 0
brk(0)                                  = 0x1887000
brk(0x18a8000)                          = 0x18a8000
brk(0)                                  = 0x18a8000
open("/usr/lib/locale/locale-archive", O_RDONLY|O_LARGEFILE|O_CLOEXEC) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=106055264, ...}) = 0
mmap2(NULL, 2097152, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb6b69000
mmap2(NULL, 1245184, PROT_READ, MAP_PRIVATE, 3, 0x19b000) = 0xb6a39000
mmap2(NULL, 4096, PROT_READ, MAP_PRIVATE, 3, 0x1162000) = 0xb6f0a000
close(3)                                = 0
open("/dev/kmsg", O_RDONLY|O_NONBLOCK|O_LARGEFILE) = 3
_llseek(3, 0, [0], SEEK_DATA)           = 0
read(3, 0x1819c, 8191)                  = -1 EAGAIN (Resource temporarily unavailable)
close(3)                                = 0
syslog(SYSLOG_ACTION_SIZE_BUFFER, 0, 0) = 262144
mmap2(NULL, 266240, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb69f8000
syslog(SYSLOG_ACTION_READ_ALL, "", 262152) = 0
munmap(0xb69f8000, 266240)              = 0
close(1)                                = 0
close(2)                                = 0
exit_group(0)                           = ?
+++ exited with 0 +++
[root@calxeda-arm-soc-04 ~]# uname -a
Linux calxeda-arm-soc-04.lab.eng.brq.redhat.com 3.9.9-302.fc19.armv7hl #1 SMP Sun Jul 7 02:30:19 UTC 2013 armv7l armv7l armv7l GNU/Linux
Comment 1 Dan Horák 2013-07-18 15:06:25 EDT
for the record:

[root@calxeda-arm-soc-04 ~]# umount /home
[root@calxeda-arm-soc-04 ~]# mount /home
[root@calxeda-arm-soc-04 ~]# dmesg
[42458.370713] EXT4-fs (dm-2): mounted filesystem with ordered data mode. Opts: (null)
[42458.370740] SELinux: initialized (dev dm-2, type ext4), uses xattr
Comment 2 Dan Horák 2013-07-18 15:50:01 EDT
hm, looks like a feature, on a fresh x86_64 machine from Beaker I get

[root@hp-dl380pgen8-02-vm-16 ~]# dmesg
[  259.056476] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.

Note You need to log in before you can comment on or make changes to this bug.