Bug 98577 - unixODBC-2.2.3-6 RPM relies on qt, but the library doesn't.
unixODBC-2.2.3-6 RPM relies on qt, but the library doesn't.
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: unixODBC (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fernando Nasser
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-03 17:54 EDT by Robert Walsh
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-08 09:54:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Walsh 2003-07-03 17:54:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
The unixODBC-2.2.3-6 RPM claims that the package is dependant on qt.  However,
an ldd of the libraries in the package shows that none of them rely on qt. 
There is a seperate unixODBC-kde package which probably does rely on qt - maybe
there's a boogum in the spec file?

Even if I'm misunderstanding an actual dependency, unixODBC should not rely on
qt - I want to install it on an embedded server that doesn't even have X
installed, which I'm sure is a common setup.

Version-Release number of selected component (if applicable):
unixODBC-2.2.3-6

How reproducible:
Always

Steps to Reproduce:
No reproduction needed.

Additional info:
Comment 1 Fernando Nasser 2003-07-04 13:10:14 EDT
The dependency is only for building the package.  As the build process is a
single one for all three RPMs we must require Qt even if it is needed for  just
one of the produced RPMs.

There is no requirements on Qt for installing the RPMs except for the kde one.
If you are being told so when trying to install theother RPMs then we have a
problem in the RPM system itself, but I find that not very plausible (it would
be immediately noticed everywhere).

Please try to install the base RPM (you can use --test if you want) and post the
printed output so we can find out what is going on.

Thanks.
Comment 2 Robert Walsh 2003-07-06 02:04:11 EDT
Here goes.  Blank lines between commands, for clarity.  Package is from disk 3
of RedHat 9:

[root@lame root]# rpm --verify unixODBC
Unsatisfied dependencies for unixODBC-2.2.3-6: libqt-mt.so.3

[root@lame RPMS]# md5sum unixODBC-2.2.3-6.i386.rpm 
99efc4708de467dd96b781b8338d43f4  unixODBC-2.2.3-6.i386.rpm

[root@lame RPMS]# rpm -qp unixODBC-2.2.3-6.i386.rpm --requires
warning: unixODBC-2.2.3-6.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
/sbin/ldconfig  
/sbin/ldconfig  
config(unixODBC) = 2.2.3-6
libX11.so.6  
libXext.so.6  
libc.so.6  
libc.so.6(GLIBC_2.0)  
libc.so.6(GLIBC_2.1)  
libc.so.6(GLIBC_2.1.3)  
libc.so.6(GLIBC_2.2)  
libc.so.6(GLIBC_2.3)  
libcrypt.so.1  
libcrypt.so.1(GLIBC_2.0)  
libdl.so.2  
libdl.so.2(GLIBC_2.0)  
libdl.so.2(GLIBC_2.1)  
libgcc_s.so.1  
libgcc_s.so.1(GCC_3.0)  
libm.so.6  
libm.so.6(GLIBC_2.0)  
libncurses.so.5  
libnsl.so.1  
libodbc.so.1  
libodbcinst.so.1  
libpthread.so.0  
libpthread.so.0(GLIBC_2.0)  
libqt-mt.so.3  
libreadline.so.4  
libstdc++.so.5  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

[root@lame RPMS]# rpm --erase unixODBC
error: Failed dependencies:
        libodbc.so.1 is needed by (installed) php-odbc-4.2.2-17.2

[root@lame RPMS]# rpm --erase unixODBC --nodeps

[root@lame RPMS]# rpm --test -Uvh unixODBC-2.2.3-6.i386.rpm 
warning: unixODBC-2.2.3-6.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
        libqt-mt.so.3 is needed by unixODBC-2.2.3-6
    Suggested resolutions:
        qt-3.1.1-6.i386.rpm

[root@lame RPMS]# rpm --test -Uvh unixODBC-2.2.3-6.i386.rpm --nodeps
warning: unixODBC-2.2.3-6.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing...                ########################################### [100%]
Comment 3 Fernando Nasser 2003-07-06 12:45:21 EDT
You are absolutely right.  The odbctest program requires Qt and is in the main
package.  I will try and move it into the kde package; hopefully this will
remove the dependency.

Thanks for bringing this to our attention.
Comment 4 Fernando Nasser 2003-07-08 09:54:08 EDT
This will be fixed on the next release.

Thanks for reporting it.

Note You need to log in before you can comment on or make changes to this bug.