Bug 98578 - slocate should not try to index /mnt/floppy
Summary: slocate should not try to index /mnt/floppy
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: slocate   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-03 21:54 UTC by Joseph Shraibman
Modified: 2007-04-18 16:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 09:27:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joseph Shraibman 2003-07-03 21:54:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
in /etc/cron.daily/slocate.cron

This line:
/usr/bin/updatedb -f "nfs,smbfs,ncpfs,proc,devpts" -e
"/tmp,/var/tmp,/usr/tmp,/afs,/net"

needs to be changed to:
/usr/bin/updatedb -f "nfs,smbfs,ncpfs,proc,devpts" -e
"/tmp,/var/tmp,/usr/tmp,/afs,/net,/mnt/floppy"


Version-Release number of selected component (if applicable):
slocate-2.6-8

How reproducible:
Always

Steps to Reproduce:
1. mount /mnt/floppy
2. eject the floppy disk without unmounting
3. Observe all the error messages in your /var/log/messages that indicate a
serious disk problem
    

Actual Results:  I saw lines like this in my /var/log/messages:
Jul  3 17:40:00 xx kernel: 02:00: rw=0, want=16, limit=4
Jul  3 17:40:00 xx kernel: Directory sread (sector 0x20) failed
Jul  3 17:40:01 xx kernel: attempt to access beyond end of device
Jul  3 17:40:01 xx kernel: 02:00: rw=0, want=16, limit=4
Jul  3 17:40:01 xx kernel: Directory sread (sector 0x20) failed
Jul  3 17:40:01 xx kernel: attempt to access beyond end of device
Jul  3 17:40:01 xx kernel: 02:00: rw=0, want=16, limit=4
Jul  3 17:40:01 xx kernel: Directory sread (sector 0x20) failed
Jul  3 17:40:01 xx kernel: attempt to access beyond end of device
Jul  3 17:40:01 xx kernel: 02:00: rw=0, want=16, limit=4

I thought that the hard disk was failing.  Turned out slocate was just trying to
access /mnt/floppy

Additional info:

redhat 8.0 also has this problem with slocate-2.6-4

Comment 1 Peter van Egdom 2003-07-05 10:53:53 UTC
Agreed. And maybe even the line :

  /usr/bin/updatedb -f "nfs,smbfs,ncpfs,proc,devpts"

should be changed to :

  /usr/bin/updatedb -f "nfs,smbfs,ncpfs,proc,devpts,iso9660,vfat,hfs"

to also exclude mounted CD-ROMs, mounted Windows partitions and mounted
Macintosh filesystems.

Comment 2 Joseph Shraibman 2003-07-06 02:37:40 UTC
I actually have some iso that are permanetly mounted via loopback, so excluding
iso's would be a good idea.

Comment 3 Joseph Shraibman 2003-07-06 02:38:01 UTC
That is would *not* be a good idea

Comment 4 Thomas Woerner 2004-10-15 18:50:08 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Comment 5 Joseph Shraibman 2004-10-15 20:54:18 UTC
This certainly is a bug, and an easy one to fix too

Comment 6 Joseph Shraibman 2004-10-15 20:56:00 UTC
Hmm.  The bugzilla email didn't show me the comment, only that you
closed the bug.  Anyway I don't have any of those distros, but you can
check if this is fixed easily by looking at the text file.

Comment 7 Joseph Shraibman 2004-10-15 20:58:58 UTC
OK I just looked at a fedora core 2 box, and it appears this bug is
still in there.

# cat /etc/updatedb.conf
PRUNEFS="sysfs selinuxfs usbdevfs devpts NFS nfs afs sfs proc smbfs
autofs auto iso9660"
PRUNEPATHS="/tmp /usr/tmp /var/tmp /afs /net /sfs /selinux /udev"
export PRUNEFS
export PRUNEPATHS

... and as I stated earlier I don't think iso9660 should be
automatically excluded.

Comment 8 Thomas Woerner 2004-10-20 09:27:06 UTC
I have added /mnt/floppy to PRUNEPATHS, but I will not remove iso9660
from PRUNEFS. These are both removable devices, therefore it makes
sense not to include them.

If you want to include your cdropm drives, then remove iso9660 from
PRUNEFS.

Fixed in rawhide in rpm slocate-2.7-12 or newer.



Note You need to log in before you can comment on or make changes to this bug.