Bug 985830 - qemu-kvm core dump when formatting scsi disk in win2k3-64 guest on rhel7 host
qemu-kvm core dump when formatting scsi disk in win2k3-64 guest on rhel7 host
Status: CLOSED DUPLICATE of bug 953822
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 06:45 EDT by guo jiang
Modified: 2014-01-05 04:57 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-05 04:57:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description guo jiang 2013-07-18 06:45:32 EDT
Description of problem:


Version-Release number of selected component (if applicable):
   Red Hat Enterprise Linux Server release 7.0 Beta(Maipo)
   kernel-3.10.0-0.rc7.64.el7.x86_64   
   qemu-img-1.5.1-2.el7.x86_64
   virtio-win-1.6.5-5.el6_4
   spice-server-0.12.3-1.el7.x86_64
   seabios-1.7.2-2.el7.x86_64
   vgabios-0.6c-9.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.Boot guest with CLI:
/usr/libexec/qemu-kvm -M pc -m 2G -smp 4,cores=4 -cpu SandyBridge -usb -device usb-tablet -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0,mac=00:34:33:a1:12:30 -uuid 7aa3f2f1-50e9-4f1e-ad87-508fb2171558 -chardev socket,id=aaaa,path=/tmp/monitor-win2k3-64-scsi,server,nowait -mon chardev=aaaa,mode=readline -name win2k3-64-scsi2 -vnc :2 -vga std -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=seabios_debug,path=/tmp/monitor-seabios,server,nowait -drive file=win2k3-64-actived.raw,if=none,format=raw,rerror=stop,werror=stop,cache=none,id=ide0-0 -device ide-drive,bus=ide.0,drive=ide0-0,id=ide1,bootindex=1 -drive file=disk2.qcow2v3,if=none,media=disk,format=qcow2,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk1 -device virtio-scsi-pci,id=bus2,bus=pci.0,addr=0x6 -device scsi-hd,bus=bus2.0,drive=scsi-disk1,id=disk1,serial=test1 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -global kvm-pit.lost_tick_policy=discard -monitor stdio

2.Install virtio-scsi driver

3.Format scsi disk

Actual results:
qemu-kvm core dump
#0  0x00007f616db29a19 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1  0x00007f616db2b128 in __GI_abort () at abort.c:90
#2  0x00007f616db22986 in __assert_fail_base (fmt=0x7f616dc714e8 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x7f617251a7e4 "r->req.aiocb != ((void *)0)", 
    file=file@entry=0x7f617251a776 "hw/scsi/scsi-disk.c", line=line@entry=286, function=function@entry=0x7f617251ae60 <__PRETTY_FUNCTION__.22141> "scsi_dma_complete") at assert.c:92
#3  0x00007f616db22a32 in __GI___assert_fail (assertion=assertion@entry=0x7f617251a7e4 "r->req.aiocb != ((void *)0)", file=file@entry=0x7f617251a776 "hw/scsi/scsi-disk.c", 
    line=line@entry=286, function=function@entry=0x7f617251ae60 <__PRETTY_FUNCTION__.22141> "scsi_dma_complete") at assert.c:101
#4  0x00007f617232deb3 in scsi_dma_complete (opaque=<optimized out>, ret=<optimized out>) at hw/scsi/scsi-disk.c:286
#5  0x00007f61722b72f2 in dma_complete (dbs=dbs@entry=0x7f6158003e20, ret=ret@entry=0) at dma-helpers.c:124
#6  0x00007f61722b7562 in dma_bdrv_cb (opaque=opaque@entry=0x7f6158003e20, ret=ret@entry=0) at dma-helpers.c:152
#7  0x00007f61722b7689 in dma_bdrv_io (bs=0x7f6174d74b90, sg=0x7f6175033600, sector_num=63, io_func=0x7f617227d8b0 <bdrv_aio_readv>, cb=cb@entry=0x7f617232de60 <scsi_dma_complete>, 
    opaque=opaque@entry=0x7f6174fb6490, dir=dir@entry=DMA_DIRECTION_FROM_DEVICE) at dma-helpers.c:222
#8  0x00007f61722b76dd in dma_bdrv_read (bs=<optimized out>, sg=<optimized out>, sector=<optimized out>, cb=cb@entry=0x7f617232de60 <scsi_dma_complete>, 
    opaque=opaque@entry=0x7f6174fb6490) at dma-helpers.c:231
#9  0x00007f617232cf8d in scsi_do_read (opaque=0x7f6174fb6490, ret=0) at hw/scsi/scsi-disk.c:349
#10 0x00007f6172278cf2 in bdrv_co_em_bh (opaque=0x7f61500032a0) at block.c:4119
#11 0x00007f617226937a in aio_bh_poll (ctx=ctx@entry=0x7f6174d5b600) at async.c:70
#12 0x00007f6172268f48 in aio_poll (ctx=ctx@entry=0x7f6174d5b600, blocking=blocking@entry=false) at aio-posix.c:185
#13 0x00007f6172269270 in aio_ctx_dispatch (source=source@entry=0x7f6174d5b600, callback=<optimized out>, user_data=<optimized out>) at async.c:167
#14 0x00007f61718e6ea6 in g_main_dispatch (context=0x7f6174d5b740) at gmain.c:3054
#15 g_main_context_dispatch (context=context@entry=0x7f6174d5b740) at gmain.c:3630
#16 0x00007f6172363eba in glib_pollfds_poll () at main-loop.c:187
#17 os_host_main_loop_wait (timeout=<optimized out>) at main-loop.c:232
#18 main_loop_wait (nonblocking=<optimized out>) at main-loop.c:464
#19 0x00007f6172264609 in main_loop () at vl.c:2029
#20 main (argc=<optimized out>, argv=<optimized out>, envp=<optimized out>) at vl.c:4419

Expected results:
Format scsi disk successfully

Additional info:
Comment 1 guo jiang 2013-07-18 06:58:34 EDT
(In reply to guo jiang from comment #0)
virtio-win-prewhql-0.1.65 hit the same issue.
Comment 5 Ronen Hod 2014-01-02 05:19:51 EST
QE,

Please retest with the latest RHEL7. Might be a duplicate of bug 953822 (that does not reproduce with the latest drivers and RHEL7).
Comment 6 juzhang 2014-01-02 05:24:47 EST
Hi Sibiao,

Could you have a try and update the result in the bz?

Best Regards,
Junyi
Comment 7 Sibiao Luo 2014-01-02 23:31:10 EST
Retried this issue with the same steps as comment #0 on qemu-kvm-1.5.3-30.el7.x86_64 which did not meet issue any more, it can finish format the scsi disk correctly.

host info:
3.10.0-64.el7.x86_64
qemu-kvm-1.5.3-30.el7.x86_64
seabios-1.7.2.2-6.el7.x86_64
guest info:
win2k3-64bit
virtio-win-prewhql-0.1-50

Best Regards,
sluo
Comment 8 Ronen Hod 2014-01-05 04:57:10 EST

*** This bug has been marked as a duplicate of bug 953822 ***

Note You need to log in before you can comment on or make changes to this bug.