Bug 985951 - Libreoffice sometimes discards heterogenous formatting in a spreadsheet text cell
Libreoffice sometimes discards heterogenous formatting in a spreadsheet text ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Eike Rathke
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 11:02 EDT by David Howells
Modified: 2014-03-19 07:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-17 12:49:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Howells 2013-07-18 11:02:02 EDT
Description of problem:

Cells with formatting changes in the middle (say ink colour changes) lose that information.  

Version-Release number of selected component (if applicable):

libreoffice-calc-4.1.0.1-8.fc19.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Open a new spreadsheet.
2. Into any cell, type "Bid 2", change the ink colour to red and then press "H".  The ink colour reverts immediately to black - which shouldn't happen.
3. Press Enter to finish entering the text.
4. Select the 2H part of the text and select red ink colour and Press enter and the colour will stick - this is correct.
5. Go back to the cell and append a character (not space).  It will appear red briefly, then the whole text will revert to black - which also shouldn't happen.  Note that this doesn't happen if a space is entered next.

The same effects can be observed if you make the characters italic rather than making them red.  Setting the cell to text format before trying this doesn't help.

Actual results:

Formatting information is discarded under some circumstances.

Expected results:

The formatting information should be retained.  It is certainly possible for the spreadsheet to do this.

Additional info:

Whilst it is possible to make the formatting apparently stick, sometimes the program will just randomly unify the formatting in every cell in one go, rather than doing it on just the cell you're working on.  This appears to be unrecoverable and could not be undone with Ctrl+Z.  This _may_ be related to document recovery after a crash as that's the only time I've seen it.
Comment 1 Eike Rathke 2014-03-17 12:49:34 EDT
Tried in 4.1.5.3-1.fc19 and couldn't reproduce, I assume this was fixed.
Comment 2 David Howells 2014-03-19 07:24:02 EDT
Works for me too (in F20).

Note You need to log in before you can comment on or make changes to this bug.